Register Hello & Welcome to AndroidTablets.net, is this your first visit?

Results 1 to 5 of 5
  1. #1
    Junior Member Achievements:
    7 days registered

    Member #
    85920
    Join Date
    Jan 2012
    Posts
    4

    Exclamation Boot Manager/Partition Table missing, can't reformat, can't find ssd in G-Parted

    Hi guys, hope someone can point me in the right direction,

    I bought a VP10 last week (listed as grade-b, or refurbished). I installed the current ICS build from android-x86.org and kept the Win 7 home prem. I could boot into both fine, no problems

    However booted into Windows this morning and it loaded up a recovery? process. (I'm not 100% as I thought it was the windows update so I left the room). Came back to find it turned off. I booted back into windows only to find it would not load. Just hangs on a blank screen. I booted into android to check and it too hung on the android loading logo! Restarted once more to check again and I can no longer access the Grub Boot loader.

    I ran the 1.6 Viewsonic android installer to start again and the partitions where missing in the where to install list (both the ext3 android and ntfs windows). I tried to format the drive again and create the parttions from scratch but I could not, getting the error sda- unable to read partition table.

    I launched G-Part live cd from USB (I am competent at this sort of diagnostic) to attempt to reformat the ssd and start over. However, two things:

    1. The first time I loaded up I was able to access the ssd within G-Part and try to make a new partition, but after some moments I got the message "Error while creating partition table."

    2. From now on I can no longer access any information about the ssd within g-part

    Also, fdisk from terminal finds no drives.

    So yeh, I've no idea how this has happened, I'm quite confident in OS installs with linux/windows and never had one go THIS wrong.

    I understand it is possible to replace the ssd but thought I would get some info here first. It's a second hand refurbished unit, so I'm not sure what the warrenty covers in this case.
    I'm in the UK also, so shipping it off to the US may be expensive!

    Thanks for any info.

  2. # ADS
    Ads
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

  3. #2
    Senior Member
    Points: 4,808, Level: 44
    Level completed: 29%, Points required for next Level: 142
    Overall activity: 0%
    Achievements:
    1 year registered 1,000 Experience Points 3 months registered 500 Experience Points 250 Experience Points

    Member #
    85490
    Join Date
    Jan 2012
    Posts
    116
    Thanked
    13 times
    Points
    4,808
    Level
    44
    Device
    Azpen X1 , HP-Touchpad
    Last year I had a partition disappear, and I was able to recover it by creating a new partition table. Unfortunately, I don't recall the program that I used, but it was a free Linux program. Here is one that I found thru Google:

    TestDisk - CGSecurity

    I also may have used the dd_rescue application. It is a terminal program, but since you are Linux experienced you shouldn't have too much trouble. Do a search for partition table restore, that is how I eventually found my solution. I believe that you can restore the partition table from a backup block.

    What ever you do, DO NOT try to do anything else before trying to restore the partition table. Writing over the existing files will make it more difficult to restore. If you remove the drive and plug it into a PC with Linux installed, it may be easier as it is a standard SATA interface. Just be VERY careful not to accidentally change the hard drive on the PC.

  4. #3
    Junior Member Achievements:
    7 days registered

    Member #
    85920
    Join Date
    Jan 2012
    Posts
    4
    Thanks for the input,

    tried every method I could to get access to the disk partitions within a linux live boot with no luck, all attempts ended in an inability to even read the drive!

    as I had no warrenty left and had the hunch that i would need to replace the drive, I decided to take it apart and transplant it into my desktop and attempt surgery with testDisk..

    again, any attempt to access the partitions, the partition table or re-write the MBR failed due to an inability to read the drive.
    disk analysis had been running for almost an hour, with a read error at every cylinder entry.. well it only got to 16/1946...

    Bios reads the drive, there is no read/write protection enabled on the drive

    Windows tried to initialise it within disk management but returned an I/O error.

    So.. to me it looks completely gone, luckily i have no important data on it so it's not much of a loss. Ill look into buying a replacement ssd.. glad I got it on offer tho!

  5. #4
    Member Achievements:
    1 year registered 500 Experience Points 1,000 Experience Points 250 Experience Points 100 Experience Points

    Member #
    24731
    Join Date
    Apr 2011
    Location
    Md
    Posts
    77
    Thanked
    9 times
    Device
    Viewpad10

    SSD format

    one last thing you can try is a low level format, if the drive is in any way recoverable it will recover the damaged drive. there are a bunch of free tools to do this but here is one to get you started, How Do I Low-Level Format a SATA or ATA (IDE) Hard Drive? it can take a few hours to complete and if it recovers it great, but if not then yeah the drive is toast.

  6. #5
    Junior Member Achievements:
    31 days registered 100 Experience Points 7 days registered

    Member #
    90464
    Join Date
    Feb 2012
    Posts
    15
    You could try the diskpart command..

    1. Boot up with your Windows Installation Disk
    2. Choose "Repair Your Computer"
    3. If after scanning it doesn't find your OS, just click next.
    4. Choose "Command Prompt"
    5. When comman prompt opens type this:

    diskpart

    It will now identify all the available storage drives and their sizes on your computer (includes your micro sd card (if any), usb thumb drives (if any)
    If it identifies your 16gb or 32gb drive then your in luck... if not, your ssd is broken....

    If it identifies a 16gb or 32gb storage select it by this command:

    select disk "number of the drive" ex. "select disk 1"
    then type:

    list partitions

    it will then show the list of partitions in your drive. Now you must identify the partition where you installed your Windows OS. Choose it by typing this command:

    select partition "number of partition" ex. "select partition 0"

    now, type the command:

    active

    it should set the partition as active and will let you boot into Windows


    Hope this helps


 

Ads:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. SDK Manager can't find Java, Win7- 64bit
    By willber in forum Coby Generation 1
    Replies: 1
    Last Post: 04-15-2012, 10:07 PM
  2. trying to find a good sd card manager
    By unix1adm in forum Acer Iconia Tab A500 Forum
    Replies: 3
    Last Post: 10-17-2011, 07:16 AM
  3. "SD Card Damaged you may have to reformat it"
    By Trantastique in forum Android Tablet Q&A
    Replies: 1
    Last Post: 09-24-2011, 07:53 AM
  4. parted resize error on dual boot prep
    By vinal in forum Nook Color Technical
    Replies: 2
    Last Post: 03-24-2011, 08:24 PM
  5. Avoiding Corrupted Boot Partition and BSOD
    By ElectronikBrain in forum Nook Color Technical
    Replies: 3
    Last Post: 03-07-2011, 08:35 AM

Search tags for this page

acer a500 partition table
,
can create new partition table
,
can't create partition table
,
can't create partition table new drive
,

error while creating partition table

,
fix android tablet partition
,
hw to make new partition table on android
,
missing partition table nook tablet
,
ssd drive lost partition table
,

ssd lost partition table

,
ssd+lost+partition table
,
viewpad 10 choose partition
Click on a term to search our sites for related topics.
Powered by vBulletin® Version 4.1.11
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Android Tablets.net is not affiliated or associated with Google, Android Project or any of the device manufacturers listed on this site.
We are simply an enthusiast site.
All times are GMT -5. The time now is 08:19 AM.