Register Hello & Welcome to AndroidTablets.net, is this your first visit?

Results 1 to 2 of 2
  1. #1
    Junior Member
    Member #
    134754
    Join Date
    Aug 2012
    Location
    UK
    Posts
    1
    Device
    Epad ZT-180 with Ruby v1.4 motherboard (full lodel name: ZT180 0102A SRTA1030S6

    Epad ZT-180 Wont Turn ON

    Hi Can you help?

    This is the description of the problem.

    I have an epad ZT-180
    The model number is ZT180 0102A SRTA1030S6
    It has a ruby v1.4 motherboard.
    When you press the power button, nothing happens.
    When you plug in the charger, the red LED comes on. Press the power button, and the blue LED comes on for 3 seconds then disappears, and the red LED comes back on. There is nothing displayed on the screen.
    Ive left the unit on to charge all day, but still no difference.
    I have opened up the unit, and everything inside looks OK. The cables are attached correctly and there is no signs of overheating.

    Ive tried pressing the reset button, but nothing happens afterwards.
    I have tried loading new firmware from the zenithink.us website but nothing happens.
    Effectively, the unit is non functioning.
    There are many users on the internet posting similar problems, but no solutions.

    Any ideas greatfully recieved particulary if you have the solution!

  2. # ADS
    Ads
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

  3. #2
    Senior Member Achievements:
    500 Experience Points 3 months registered 250 Experience Points 31 days registered 100 Experience Points

    Member #
    112363
    Join Date
    May 2012
    Posts
    132
    Thanked
    23 times
    Device
    zt280 c91 upgrade
    Could the power button be faulty? As in does absolutely nothing happen at all in any way?

    Sent from my ZT282
    1.0ghz modified Zenidroid rom


 

Ads:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Help! My White Pd Novel wont turn on.
    By sandra6482 in forum Pandigital Novel
    Replies: 0
    Last Post: 05-25-2012, 07:31 PM
  2. My Kyros wont turn on....
    By Princessrobyn in forum Coby Generation 2 Technical
    Replies: 1
    Last Post: 03-20-2012, 11:59 PM
  3. Apad wont turn on ??? please help ???
    By em.chid in forum Android Tablet Q&A
    Replies: 2
    Last Post: 04-13-2011, 04:04 AM
  4. my tablet wont turn on
    By awatermski in forum Android Tablet Q&A
    Replies: 4
    Last Post: 01-30-2011, 02:39 PM

Search tags for this page

ePad ZT-180
,
ePad zt-180 android tablet
,
epad wont charge
,

epad wont turn on

,

my epad wont turn on

,
what could cause zt180 to not power up
,
zepad zt 180 wont power on
,
zt pad android turn on
,
zt pad charge light
,
zt-180 wont power on
,
zt-180 wont turn on
,
zt180 upad charging problem
Click on a term to search our sites for related topics.
Powered by vBulletin® Version 4.1.11
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Android Tablets.net is not affiliated or associated with Google, Android Project or any of the device manufacturers listed on this site.
We are simply an enthusiast site.
All times are GMT -5. The time now is 10:50 AM.