3.1 and 'mobile' websites

Discussion in 'Acer Iconia Tab A500 Forum' started by charlieg64, Jul 7, 2011.

  1. charlieg64

    charlieg64 Member

    Joined:
    May 29, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Swindon
    Tablet / Device:
    Acer Iconia A500
    Since the 3.1 update the BBC website defaults to mobile version. There may be more. Using stock and Dolphin browsers and both the same. Even more irritating is no access to iPlayer any more because of this. I know I can save preferences for the dektop site in the websites settings but this doesn't hide the fact that this is an issue that needs fixing,

    Any other UK users experiencing this and if so have you found a workaround?

    If I could I'd go back to previous version.
     
  2. whitegoose

    whitegoose Member

    Joined:
    May 21, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Perth, Australia
    Tablet / Device:
    Acer Iconia A500
    I get the same thing
     
  3. whitegoose

    whitegoose Member

    Joined:
    May 21, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Perth, Australia
    Tablet / Device:
    Acer Iconia A500
    okay this is driving me crazy now, i've set both the Viewing Mode and the UAString to "Desktop" and i'm still getting the mobile site for websites that worked fine on 3.0

    Anybody got an idea?
     
  4. pwalt

    pwalt Member

    Joined:
    Dec 1, 2010
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    87
    Location:
    Columbus, Ohio
    Tablet / Device:
    Huawei S7
    In the debug mode, then settings, there's an "Advanced" tab ... here there's another mobile vs desktop radio button to click. I don't know why there's two locations to adjust one setting ... but there are. Everything seems to work for me again.

    Edit for spelling <sigh>
     
  5. Uncron

    Uncron Member

    Joined:
    May 19, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Ottawa Canada
    Tablet / Device:
    Acer A500
    How to make Android's Honeycomb browser load desktop not mobile Web sites

    1. Open the Android Honeycomb browser on your tablet.
    2. In the address bar, type: about:debug and press enter.
    3. Now open the browser's settings by tapping the icon in the very top-right corner of your screen (it looks like four horizontal lines) and selecting "Settings" from the drop-down menu that appears.
    4. On the left side of the screen, tap the section labeled "Debug."
    5. On the right side of the screen, tap the item labeled "UAString," then select "Desktop."
    6. Press the back button (in the very bottom-left corner of your screen) to exit the browser's settings.
    7. In the browser's address bar, type: about:debug once more; this will disable debugging mode and return the browser to its normal state.
     
  6. pwalt

    pwalt Member

    Joined:
    Dec 1, 2010
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    87
    Location:
    Columbus, Ohio
    Tablet / Device:
    Huawei S7
    Possibly without going through the debug string ...

    Go to browser settings, then "Advanced" ... Viewing mode (desktop vs tablet) is an option there.

    After the 3.1 update I changed it via the debug instructions and it didn't work. Then I found the other option while nosing around.
     
  7. Icebike

    Icebike Senior Member

    Joined:
    Apr 28, 2011
    Messages:
    1,523
    Likes Received:
    186
    Trophy Points:
    310
    And you tested this on the the mentioned site BBC - Homepage right?
     
    Last edited: Jul 7, 2011
  8. pwalt

    pwalt Member

    Joined:
    Dec 1, 2010
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    87
    Location:
    Columbus, Ohio
    Tablet / Device:
    Huawei S7
    Well crud ... that one is loading as mobile. (and yes, the debug UAString is set to desktop AND the other View setting is set to desktop)

    I'm having no problems with www.dispatch.com (my local paper) ... and they have a mobile version. Interesting.

    The Wall Street Journal works as well ... Business News & Financial News - The Wall Street Journal - Wsj.com

    I wonder what BBC is looking at to see if you're on a desktop or mobile device?
     
  9. omnisvalidus

    omnisvalidus Member

    Joined:
    May 9, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    UK
    Tablet / Device:
    Acer A500 and Motorola Xoom 3G
    At the bottom of the BBC Mobile site there is an options link. If you click on this you get an option to go back to the full site which seems to work. Don't know how long it will remember the setting yet though.
     
  10. Icebike

    Icebike Senior Member

    Joined:
    Apr 28, 2011
    Messages:
    1,523
    Likes Received:
    186
    Trophy Points:
    310
    PWalt:

    I think its a caching issue.

    If you go to http:www.bbc.uk.co/news/ it usually shows up correctly.

    Then Tap the BBC logo to jump back to their main page and it seems to stay in Desktop mode (presuming you made the desktop setting).
    From then on it seems to stay in desktop mode.
     
  11. charlieg64

    charlieg64 Member

    Joined:
    May 29, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Swindon
    Tablet / Device:
    Acer Iconia A500
    It's not the mobile version of websites that's bugging me, I knew all the work arounds pre 3.1. The issue is I can no longer access BBC iPlayer because the website thinks my 'phone' is not campatable Roll back to 3.0.1!!
     
  12. colin6walker

    colin6walker Member

    Joined:
    May 27, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    England
    Tablet / Device:
    Acer A500
    I agree with you. I've tried to use all the other tips in this thread but nothing has worked, I have no idea how to roll back though!
     
  13. omnisvalidus

    omnisvalidus Member

    Joined:
    May 9, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    UK
    Tablet / Device:
    Acer A500 and Motorola Xoom 3G
    Tgere do seem to be some sites that refuse to cooperate. Movuefone.com is another. What makes it worse is that my Froyo phone has no problem with it even in the default browser. I would love a solution to this.
     
  14. colin6walker

    colin6walker Member

    Joined:
    May 27, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    England
    Tablet / Device:
    Acer A500
    I've found a work around to get BBC iplayer up. It's not perfect but it works.
    First install iplayer app then open the android browser & go into the debug menu (as described by Uncron earlier in this thread)
    Set th UAstring to FROYO N1 close the browser then open the iplayer app & set it's default to the android browser. I hope this helps, I'll keep an eye on this thread for better suggestions

    I have to eat humble pie here! this fix only works when in the debug mode & it won't stay there for long so you have to open the default browser & type about:debug almost every time!
     
    Last edited: Jul 10, 2011
  15. whitegoose

    whitegoose Member

    Joined:
    May 21, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Perth, Australia
    Tablet / Device:
    Acer Iconia A500
    My issue is with News.com.au | News Online from Australia & the World | NewsComAu which is the news website i frequent... it used to open fine on HC 3.0 but now on 3.1 I always get the mobiles site even though I have both the normal setting and the debug UAString to "desktop"... and the mobile site doesn't have a "show full website" option. Can someone else test the site for me to confirm?

    I installed firefox to test and using firefox i get the full site not the mobile site.

    Any help appreciated as this website is what i read on my tablet every morning while eating breakfast, everything was perfect, and now it's not :(
     

Share This Page