A2109 INCOMPATIBLE Freedom Pro Keyboard (28 Mar 2013)

Discussion in 'Lenovo IdeaTab A2109 Accessories' started by ardentblue, Mar 28, 2013.

  1. ardentblue

    ardentblue Junior Member

    Mar 20, 2013
    Likes Received:
    Trophy Points:
    Tablet / Device:
    Lenovo IdeaTab A2109A
    I had hoped the SPP / HID dual mode Freedom Input "Freedom Pro Keyboard) would be able to function with 4.1.1, but it was not seen, either as a SPP or HID device.

    Installed 4.0.4, tried to install the app, which is not on Google Play Store (form your own opinions on that). Finally installed, then tried to pair the FPK. Got it to pair, under HID. A2109 shows it paired. Enabled FPK as an input device. Chose it as default input keyboard.

    You cannot input any text into Google, FireFox, or other apps.

    It does work under Win7. Pairing is a little odd, because when you type text into the text box, it shows no input. Hit the enter button anyways. It is there. I typed some text into a Word document without issue.

    IMHO, the app is toast. Maybe Blueinput would work, but this much diddling with the manufacturer's app tells me that I don't want to depend on Freedom Input. I'm sending the Freedom pro Keyboard back.

Share This Page