Acer Iconia ICS not connecting to computer.

Discussion in 'Acer Iconia Tab A500 Forum' started by Lee_Walk, Jan 1, 2014.

  1. Lee_Walk

    Lee_Walk Member

    Dec 30, 2013
    Likes Received:
    Trophy Points:
    Tablet / Device:
    Acer Icona A500
    Alright I have been all over here, the other forums; and Googled. I have an Acer Iconia A500, Running ICS 4.0.3, my computer is Windows 7. I have downloaded things from those sites, nothing. Directly from Acer, nothing; to make matters worse they don't provide any drivers for ICS USB. When I connect I get the option of either MTP or PTP. Neither work, in Device Manager it shows a yellow triangle. And don't say connect it wireless, I don't want to do that unless it will allow me to try and root it. I have tried Iconiaroot, but I cant downgrade the ROM to 3.1, whether its cause it physically won't let me; or the files are bunk. And yea I have been all over for that too...

    Attached Files:

  2. Douvie

    Douvie Senior Member

    Jun 10, 2011
    Likes Received:
    Trophy Points:
    Kyneton, Australia
    Tablet / Device:
    Acer Iconia A500 & Sumsung Galaxy Note 10.1

    I've had a problem with win7 which can cause this issue. My PC would not connect to the tablet, nor could I insert a USB STICK that had been plugged into my A500. I put up with the issue for a long time. Then my HDD in my PC failed. I bought a new HDD, reloaded win7 and now I have no problem. Everything works.

    If you're having the same problem you may have to reload win7 afresh with all the mobo drivers updated. Don't try a "repair" it will not work - I tried that too.


Share This Page