Bell Galaxy Tab 8.9 LTE cannot get Netflix or Android Videos to work

Discussion in 'Samsung Galaxy Tab 8.9' started by smoore, Dec 13, 2011.

  1. smoore

    smoore Member

    Dec 13, 2011
    Likes Received:
    Trophy Points:
    Tablet / Device:
    Galaxy Tab 8.9 LTE
    I just recently purchased the above tablet from Bell. It works well except for two programs. Netflix downloads but cannot open. When I attempt to open it the screen starts to zoom, turns back and then it immediatley reverts back to the screen I was on. I have tried a soft reset, deleting and reinstalling the app, deleting cache and data but nothing works. Android Apps downloads and I can open it. But if I try and pin a video I have purchased or stream it I get a "fail to fetch license error 43" error message. I have also tried the above fixes for it without success (in fact, Android advised to delete cache and data and reboot and when I advised them this did not work, they did not reply).

    I have no way of knowing if this is true for all Bell Galaxy Tab 8.9 (I know that the 10.1 runs both applications on Rogers).

    I have attempted to get help from Samsung, Bell and Netflix and they all blame each other.

    If anyone has any suggestions that would be helpful. Even if you can confirm that the problem is not limited to my tablet, then I know it is a software and not a hardware problem and I can wait for a software fix from both companies. ​


    Just to add some information. I went to a Bell World store and we installed both programs on a brand new Tab 8.9 and it had exactly the same problems. This suggests to me that it is not a hardware problem but possibly a problem with the Bell version of Android 3.2

    I have also posted these comments in the Video thread. ​


Share This Page