Can No Longer Upgrade VI30

Discussion in 'Onda Tablet Forum' started by huangdi, Dec 9, 2012.

  1. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    Current state of my onda vi30:
    - android version 4.03 (official version, no access to play store (error 101))
    - unable to upgrade to 4.1.1. :
    +during recovery the white android appears,
    + the white android very shortly disappears
    + and the tablet continues with a normal boot

    So, how did I get in this mess:
    - I upgraded to 4.1.1.
    - I downgraded to 4.03, because 4.1.1. didn't give me root access

    My, not so very informed, analysis;
    - I don't have a decent recovery partition

    So, how to get back to a normal situation in which I can upgrade to 4.1.1.
    (and obtain root access as described in the other threads) ?

    Is there a way to restore the recovery partition? (if that is indeed the problem)

    Thanks for reading this.
     
  2. iiDiabolusZz

    iiDiabolusZz Senior Member

    Joined:
    Nov 9, 2012
    Messages:
    441
    Likes Received:
    113
    Trophy Points:
    132
    Location:
    Newcastle, England
    Tablet / Device:
    Onda V701
    Hi, inside the firmware package you downloaded from onda drag the following files to the sdcard -

    factory_update_param.aml
    u-boot.bin
    uImage
    uImage_recove
    update.zip
    patch.zip

    Then boot to recovery, when the white droid appears let go of keys, it may stay on for a while then go off, it will then reappear then the green droid will show(fingers crossed) it will then install along with new boot section.
    If for any reason it wont install let me know and i will write a recovery file for you to use.
     
  3. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    Thanks for your quick reply. It sounds promising! I will follow your instructions in the course of this week.

    -huangdi
     
  4. iiDiabolusZz

    iiDiabolusZz Senior Member

    Joined:
    Nov 9, 2012
    Messages:
    441
    Likes Received:
    113
    Trophy Points:
    132
    Location:
    Newcastle, England
    Tablet / Device:
    Onda V701
  5. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    I tried this new guide (a few times), but recovering gives a black screen for several minutes after releasing both keys on appearance of white android. So, I guess it is switched off and recovering/updating is not working. Anything else I can try, or is this the time to ask you politely to make a special recovery file for me, as you above suggested?
     
    Last edited: Dec 11, 2012
  6. iiDiabolusZz

    iiDiabolusZz Senior Member

    Joined:
    Nov 9, 2012
    Messages:
    441
    Likes Received:
    113
    Trophy Points:
    132
    Location:
    Newcastle, England
    Tablet / Device:
    Onda V701
    Are you using the the correct firmware V1/V2?
     
  7. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    Just to be sure I just tried again: I copied from VI30D_v2.0-1129SD.zip patch.zip, update.zip, and factory_update_param.aml
    to the root folder of my external SD card. The effect is still that the system goes to a black screen after releasing both buttons when the white android appears. Any ideas?
     
  8. iiDiabolusZz

    iiDiabolusZz Senior Member

    Joined:
    Nov 9, 2012
    Messages:
    441
    Likes Received:
    113
    Trophy Points:
    132
    Location:
    Newcastle, England
    Tablet / Device:
    Onda V701
    Have you tried a factory reset from the settings? its under security, do full with wipe sdcard.
     
  9. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    I just tried it, but it makes no difference; (It was under Settings/Backup&reset).
     
  10. iiDiabolusZz

    iiDiabolusZz Senior Member

    Joined:
    Nov 9, 2012
    Messages:
    441
    Likes Received:
    113
    Trophy Points:
    132
    Location:
    Newcastle, England
    Tablet / Device:
    Onda V701
    Your going to have to try the usb method, you need windows xp 32bit or windows 7 32bit.
     
  11. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    Hmm, I need to find a windows PC :-( I guess using a virtual machine is not a good idea. Any thoughts on linux tools that can do the same.

    Just to be sure, I guess the usb method uses the tool as provided with the vi30d_v1.5.5 firmware.
    Can I use it to write v2.0 firmwares (they come without a usb burning tool) ?
     
  12. iiDiabolusZz

    iiDiabolusZz Senior Member

    Joined:
    Nov 9, 2012
    Messages:
    441
    Likes Received:
    113
    Trophy Points:
    132
    Location:
    Newcastle, England
    Tablet / Device:
    Onda V701
    Have you tried reformatting your sdcard FAT32. or tried another sdcard, i have just had a reply on my thread that it has worked 100% on vi30
     
  13. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    Reformatting the sdcard did not do it.
    I am right now trying to use the amlogic usb burning tool. The current status is that it stopped burning at 73% with an error. In another thread I found that that had to do with the language settings in windows. I changed Dutch to English and redid the procedure. However, now the device can no longer be handled in the intended way and, consequently it is not seen by the burning tool :-(

    The procedure is simpel and worked the first time around:
    1. switch off the device
    2. keep home button pressed while
    a. connecting usb cable to PC,
    b. waiting for battery loading icon to appear (does not happen anymore!!)
    c. pressing on/off switch for 4 seconds
    3. let both buttons go.
    4. At this point windows should recognize your device
    5. ....

    The second time around the battery icon does not appear but the white droid (sic!) appears and it tries to boot normally, but gets stuck in the onda screen.

    So, what now? I am guessing step 1 failed. Any other way to shutdown completely, other than holding down the on/off button for a long time. Maybe I have to drain the battery completely?
     
    Last edited: Dec 18, 2012
  14. iiDiabolusZz

    iiDiabolusZz Senior Member

    Joined:
    Nov 9, 2012
    Messages:
    441
    Likes Received:
    113
    Trophy Points:
    132
    Location:
    Newcastle, England
    Tablet / Device:
    Onda V701
    It needs to be english version of windows xp 32/ windows 7 32 and programs must be run with administrators privileges when flashing with usb, also make sure it is charged for atleast a hour, battery needs to be more than 50%.
     
  15. huangdi

    huangdi Member

    Joined:
    Dec 7, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Netherlands
    Tablet / Device:
    Onda Vi30D 8GB
    I am using win7, 32 bit, device has been on power for two hours. I can not see what the battery level is, since the boot process gets stuck in the onda logo.
    I am unsure what administrator priviliges, I have, but I could install devices drivers, so that might be okay. However, the process as described before does no longer bring the "worlcup device" alive for the burning tool to see it. So, I can not even retry the usb burning process; the tool sometimes sees that usb port 5 is used, but it doesn't recognize the tablet as being on that port. Any other thoughts?
     

Share This Page

Search tags for this page

onda vi30 firmware

,
onda vi30 firmware update
,
onda vi30w firmware update
,
upgrade onda vi30 deluxe