Can Not Open Google Apps/Want to Watch Movies

Discussion in 'Android Tablet Q&A' started by Droid867, May 8, 2014.

  1. Droid867

    Droid867 Junior Member

    May 8, 2014
    Likes Received:
    Trophy Points:
    Tablet / Device:
    Unisurf Android Tablet
    Hey all, I am new here and new to using my tablet, so if anyone could help I would definitely. Aprreciate it.:)

    I have two questions .

    1. So I tried to install Google Play services>. okay. once installed, I installed Two other apps. Google plus and Hangout app (for gmail) . But every time I try to open those two apps, I get the same answerr pop up on screen telling me I need to update Google play services. I tried to update via mobile market, but i t didn't Change anything. So I then tried to uninstall then reinstall it. Instead of uninstalling it, it gave me the option to replace Google play services with Google play settings which i did. . Now I can't uninstall it and I can't install Google play services again.I also can't access my YouTube app. Now I know its not that big of a deal but I would love if anyone can understand and answer my question!

    2. is there a specific android media app you must have in order to watch movies on your android. I have been told that you can download movies off the computer and place them on a mini USB that you can plug into your tablet and watch them but I also have been told that you need a media app to play them with<. so my question is whether you need a specific media app.

    thanks in advance;)
  2. leeshor

    leeshor Senior Member

    Dec 27, 2011
    Likes Received:
    Trophy Points:
    Norcross, GA
    Tablet / Device:
    Samsung Galaxy Tab S 10.5
    Welcome to the forum

    I'm going to take a SWAG at this and suggest you go to the app manager - swipe to all and find the Google Framework app. Tap it, tell it to clear the cache then restart your tablet and try again.

Share This Page