Can this be moded to be upgraded?

Discussion in 'Marvell Based' started by Neuro, Aug 23, 2010.

  1. Neuro

    Neuro Member

    Joined:
    Aug 22, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    NULL
    I like this unit, but it runs Android 1.5, and cannot be updated. Does anyone know if there is any way to mod this unit to run newer releases?

    Thanks!

    Unit to be Mod-ed
     
  2. gurgle

    gurgle Super Moderator Staff Member

    Joined:
    Aug 6, 2010
    Messages:
    1,463
    Likes Received:
    130
    Trophy Points:
    162
    Location:
    Near 39.11°N 94.6°W
    Tablet / Device:
    Better question What don't I own, Oh a generic APAD
    The real problem with most units that are "stuck" with 1.5 or 1.6 is how powerful the chip created, what chipset used, and who developed the unit. Most units developed for 1.5 might (I repeat Might) be possible to update to 1.6 if the provider/producer made plans for upgrade. Most low end or early designs with 1.5 are stuck with the 1.5 OS. I do not want to raise your hopes.
    The link you show indicates they offer a 2.1 unit, but note it is powered by the more powerful Telechips 8902 800MHz ARM11 processor.
    Think of this comparison, some of the processors which run 1.5 are comparable to a Pentium (NOT Pentium 2/3/4) processor on a desktop computer. While some can run Windows 95 to Windows 2000, it does not mean it was ever capable of running XP. You might be able to load XP on a Pentium but you would not be happy. And you definitely could not run Windows 7.
    Sorry for the following Intel/Windows metaphor
    Think of your Marvell processor Tablet like a Pentium or PII, The Telechips like a Pentium 4. and the Snapdragon like a Core 2 Duo. In the same sense, 1.5 is like Windows 95/98, 1.6 like Windows 2000 and 2.1/2.2 like XP. The Marvell could not make it past 1.6(Windows 2000) in capability, The Telechips would be able to do 2.1/2.2 but may struggle with 3.0 And the Snapdragon able to easy do 2.2 and capable for 3.0.

    Bottom Line: You might find someone who has cooked a better firmware. But do not expect it to do anything beyond 1.6



     

Share This Page