Epad ZT-180 Wont Turn ON

Discussion in 'Zenithink Tablets' started by josephobrien2000, Aug 11, 2012.

  1. josephobrien2000
    Offline

    josephobrien2000 Junior Member

    Joined:
    Aug 11, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    UK
    Tablet / Device:
    Epad ZT-180 with Ruby v1.4 motherboard (full lodel name: ZT180 0102A SRTA1030S6
    Hi Can you help?

    This is the description of the problem.

    I have an epad ZT-180
    The model number is ZT180 0102A SRTA1030S6
    It has a ruby v1.4 motherboard.
    When you press the power button, nothing happens.
    When you plug in the charger, the red LED comes on. Press the power button, and the blue LED comes on for 3 seconds then disappears, and the red LED comes back on. There is nothing displayed on the screen.
    Ive left the unit on to charge all day, but still no difference.
    I have opened up the unit, and everything inside looks OK. The cables are attached correctly and there is no signs of overheating.

    Ive tried pressing the reset button, but nothing happens afterwards.
    I have tried loading new firmware from the zenithink.us website but nothing happens.
    Effectively, the unit is non functioning.
    There are many users on the internet posting similar problems, but no solutions.

    Any ideas greatfully recieved particulary if you have the solution!
  2. benadlam
    Offline

    benadlam Junior Member

    Joined:
    May 6, 2012
    Messages:
    132
    Likes Received:
    23
    Trophy Points:
    0
    Tablet / Device:
    zt280 c91 upgrade
    Could the power button be faulty? As in does absolutely nothing happen at all in any way?

    Sent from my ZT282
    1.0ghz modified Zenidroid rom

Share This Page