Factory Restore Ruined Maxtouch A20 Tablet

Discussion in 'Android Tablet Q&A' started by Adog, Dec 25, 2013.

  1. Adog

    Adog Member

    Joined:
    Dec 25, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    35
    I received a Maxtouuch A20 tablet for Christmas this morning and I installed a bunch of apps. One of which was the Sky Go Tablet app so I could watch some movies. When I went to watch it I wasn't allowed because it said my device was rooted. I then attempted to unroot my device by using the superuser app thing and unrooting it that way which didn't work, nor did some es app to delete the files but I couldn't even do that because it said it was 'read-only'. As none of these methods worked I thought the best thing to do would be to restore to factory default settings. What an awful mistake that was! It has been on the loading screen for the past 8 hours. I fiddled around with some buttons and it came up with a screen that allowed me to reboot it and wipe data and I've clicked on them and they have done that but then when restarting again it still gets stuck on the never ended loading phase. I tried the maxtouuch website and they had a link to reflash the firmware but the link is broken. Don't know what to do. My Christmas has been fairly crap as I spent so long looking forward to this tablet but it's just resulted in me spending all day trying to find a solution to fix it. In future I will definitely dodge the cheap Chinese products and head straight for the trusted tech.

    Anyone know what to do?
    Thanks
     

Share This Page

Search tags for this page
maxtouch hard reset
,
1how tmaxtouuch tab wipe1
,

china tablet flashfile maxtouuch a20

,
como reseatar maxtouch
,
how to factory reset maxtouuch tablet
,
how to wipe maxtouuch
,
kode pormat android tab maxtouch
,
maxtouch a20 tablet flashfile
,
maxtouch hard reset
,
maxtouch tablet pttern reset
,
maxtouuch a-20
,
maxtouuch reflash
,
maxtouuch restore
,
maxtouuch tablet forgot password
,

maxtouuch tablet hard reset

,
maxtouuch tablet hard reset code
,
maxtouuch troubleshooting
,
recovery maxttouch
,
wipe my maxxtouch t