HELP! MID VIA 8650 not booting after charge

Discussion in 'WonderMedia WM8650 Tablets' started by frustratedmum, Aug 17, 2011.

  1. frustratedmum

    frustratedmum Member

    Aug 17, 2011
    Likes Received:
    Trophy Points:
    Tablet / Device:
    mid via 8650
    Pls pls anyone help. Bought MID VIA 8650 tablet from DH Gate- (like chinese ebay) received fine last week appeared to work well on start up, set it up to wifi, tried few sites and played angry birds on it thought had no issues . Battery initially only had enough power for a couple of minutes. As it was bought for present just put it onto charge then packed away ready till sons birthday few days later. When come to use it led turns green when press power button but thats it nothing else happens. No android on screen, no vibrate, nada. Tried turning it on whilst connected to charger but it won't boot then either. Led shows red when charger connected.

    Don't know if should try factory reset button - or if that will cause further damage and may void warranty. Waiting for vendor to come back to me.

Share This Page

Search tags for this page

via8650 hard reset