How to Change MID701 Display from Chinese to English?

Discussion in 'Android Tablet Q&A' started by Jerihogan, Nov 20, 2011.

  1. Jerihogan
    Offline

    Jerihogan Junior Member

    Joined:
    Nov 19, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Capistrano Beach, CA USA
    Tablet / Device:
    android mid701
    I have 1 of those generic MID701 Epad from China & haven't been able to get it to connect to WiFi, so I read somewhere that sometimes you need to restore the system to factory condition to get every to work right..well I did that and everything came up great, I think, don't really know, cuz it's in Chinese and I don't read Chinese and can't seem to get it to go back to all English....I'm so frustrated with this GREAT BARGAIN :mad::( I got on Ebay, that I'm ready to take it to one of those techie PC repair places and pay 3x what it's worth just to get it working. Anyone have any ideas about how to get it to display English? And, I've read the threads about others who couldn't connect to WiFi with this same model - have any of them fixed that problem?
  2. Spider
    Offline

    Spider Administrator Staff Member

    Joined:
    Mar 24, 2011
    Messages:
    13,919
    Likes Received:
    1,662
    Trophy Points:
    113
    Location:
    Chicago, IL
    Tablet / Device:
    NOOK Tablet Stock NOOKcolor Rooted/Flashed Nexus 7 (2013) 32GB
    Hello Jeri, welcome to Android Tablets. Nice to have you with us as a member of the forum. I'm moving your thread over to the Android Tablet Q&A section to see if someone can help you get that display back to English. Good luck!
  3. AtlantaTerry
    Offline

    AtlantaTerry Junior Member

    Joined:
    Jul 5, 2011
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Atlanta, Georgia USA
    Tablet / Device:
    none yet
    Take it with you and go have lunch at a Chinese restaurant. After your meal, ask one of the young folks there to help you.

    When you reset the tablet and reboot you should be at the Home page with several default icons in place.

    click on: Settings (the icon is round and looks like a vehicle tire)
    click on: Language & keyboard (the icon is a small white square with a black "A" in it) (on mine it's the 10th one down)
    click on: Select language (on mine it's the first one)
    scroll down until you see the language you want and click on that

    Finished!

    If nothing else, just blindly click on the icons or positions I have described. LOL

    Terry Thomas
    Atlanta, Georgia USA
    • Like Like x 2
  4. userbe1155
    Offline

    userbe1155 Junior Member

    Joined:
    Nov 8, 2011
    Messages:
    698
    Likes Received:
    55
    Trophy Points:
    28
    Location:
    plymouth
    Tablet / Device:
    wm8650
    hi, also check out more android tablets/wondermedia based section of the forum for info and links to many issues including rooting, wifi,custom roms etc.

    Sent from my M9701 using Android Tablet
  5. JohnMWalsh
    Offline

    JohnMWalsh Junior Member

    Joined:
    Apr 10, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Roseville, CA
    Tablet / Device:
    Unknown
    I am having the same problem. Did you find the answer?
  6. mythica
    Offline

    mythica Junior Member

    Joined:
    Jul 1, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Salt Lake City, Utah
    Tablet / Device:
    Mid A13
    You are my HERO!!!
  7. anica
    Offline

    anica Junior Member

    Joined:
    Nov 23, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    zagreb
    Tablet / Device:
    android I8090
    Hi everyone, I see these posts are all old but I need a help, I'm not living near any Chinese restaurant and I'm in the same situation as Jerihogan, how did you solve it?

    I have android I8090 and had a same problem with not connecting to the internet so I restore to the factory settings and now it's all in Chinesee.

    Please help, pleasee

Share This Page