I rolled back from 4.1.1 to 4.0.4 and now I've lost fastboot

Discussion in 'Lenovo IdeaTab A2109' started by FloRider, Dec 12, 2012.

  1. FloRider

    FloRider Senior Member

    Joined:
    Dec 2, 2012
    Messages:
    358
    Likes Received:
    111
    Trophy Points:
    240
    Location:
    Florida
    Tablet / Device:
    Lenovo A2109
    I can boot into ICS using the stock ROM and kernel, but now when I load fastboot, I just get the message:
    Starting Fastboot USB download protocol
    The second line of text usually present is missing.
    Code:
    fastboot devices
    shows nothing. Same with ADB. Clockworkmod is gone. Instead, the first line of text is "Android system recovery <3e>". I also see the android with the upset stomach, as if something is trying to install. There are no .zips in the sdcard root. It still says
    Code:
    Finding update package...
    Opening update package...
    Verifying update package...
    E:failed to open /sdcard/update.zip (No such file or directory)
    E:signature verification failed
    Installation aborted.
    I get the same result if I put the 4.0.4 ROM on sdcard as update.zip. But I could clear everything up if I only had fastboot.

    Thanks!
     
  2. anika200

    anika200 Member

    Joined:
    Dec 2, 2012
    Messages:
    54
    Likes Received:
    30
    Trophy Points:
    87
    Location:
    Maryland, US
    Tablet / Device:
    Lenovo A2109
    So, how did you roll back? Have you enabled usb debugging in developer settings?
     
    • Like Like x 2
  3. FloRider

    FloRider Senior Member

    Joined:
    Dec 2, 2012
    Messages:
    358
    Likes Received:
    111
    Trophy Points:
    240
    Location:
    Florida
    Tablet / Device:
    Lenovo A2109
    Ha! That was it. Thanks! I think I'll be ok now.
     
  4. mcl630

    mcl630 Senior Member

    Joined:
    Dec 3, 2012
    Messages:
    171
    Likes Received:
    125
    Trophy Points:
    132
    Location:
    Illinois, USA
    Tablet / Device:
    Lenovo IdeaTab A2109A, Archos A101IT
    I think they changed the USB IDs for fastboot in JB... I kept having to re-setup the fastboot drivers when switching back and forth between ICS and JB.
     
  5. FloRider

    FloRider Senior Member

    Joined:
    Dec 2, 2012
    Messages:
    358
    Likes Received:
    111
    Trophy Points:
    240
    Location:
    Florida
    Tablet / Device:
    Lenovo A2109
    I noticed that there are fastboot device ids in 4.1.1.
     
    Last edited: Dec 12, 2012
  6. anika200

    anika200 Member

    Joined:
    Dec 2, 2012
    Messages:
    54
    Likes Received:
    30
    Trophy Points:
    87
    Location:
    Maryland, US
    Tablet / Device:
    Lenovo A2109
    Finally got around to re-root and CWM install and here are my observations from linux point of view. All things seem to be the same here, the Idvendor id is the same but the idProduct changes depending on if you are in fastboot or regular usb debug which is normal.

    There does seem to be a whole new bootloader with some different fastboot interactions. The fastboot now boots into an interactive menu where you can select several options, cool. Maybe we are moving towards a unified bootloader/fastboot thing. When you put the device into fastboot mode and issue "fastboot devices", you no longer get a response But all things are still functioning.
     
    Last edited: Dec 13, 2012
  7. FloRider

    FloRider Senior Member

    Joined:
    Dec 2, 2012
    Messages:
    358
    Likes Received:
    111
    Trophy Points:
    240
    Location:
    Florida
    Tablet / Device:
    Lenovo A2109
    I'd be very happy if we could use nvflash...
     

Share This Page