Imito IM7 firmware upgrade, screen calibration mishap

Discussion in 'Telechips TCC8902 Tablets' started by haon, Mar 1, 2011.

  1. haon

    haon Member

    Joined:
    Mar 1, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    sweden
    Tablet / Device:
    Imito IM7
    Hi!

    Sorry for a long post, it's in part to remember what the * I've done, and in part to perhaps help someone else and save them from alot of googling.

    A free tip: Do not calibrate your screen after you've updated the firmware.

    I followed instructions posted by magnus_olsson80 in his thread http://www.androidtablets.net/forum/telechips-based/1941-imito-im7-woes.html and successfully updated the firmware of my imito to #215. I was a bit confused about the adb erase'-commands, but I eventually found out that I just needed to use the fastboot commands to push the update to the device.

    For people looking to update, i used 'adb devices' to start the adb server (i'm running xubuntu on my laptop) and then started in "flash mode" by resetting the device while holding the "back" button. then I used the fastboot flash-commands listed in magnus_olsson80-s thread and everything worked great for me.

    But the I was stupid enough to try to recalibrate my screen using the stock app installed on IM7. it seemed to work ok but when I rebooted my device the screen was unresponsive. After fiddling with it a while I realized that if i push the home-button on the back of the device I got past the slide to unlock-screen, and could open the home-menu. I couldnt press any of the menu entries however, but if I pressed to the farthest right of the screen the menu would disappear, so my screen was indeed working. I realised that my calibration had screwed something up.

    After an initial google I started looking for a pointercal file to restore factory settings, with no avail.

    Ok, so I decided that I needed to start the calibration program via ADB to perform another calibration. shouldn't be a big deal.
    So after googling and googling and googling, i found a tip to dump system info to a local file(shell command 'adb shell dumpsys > dumpsys.txt') to find (among many other things) what activities you could call within the device and called this for the calibration program (from ADB shell):

    am start -a android.intent.action.MAIN -n com.android.calibrate/.AndroidCalibrate

    the initial crash-course for the 'am'-command came from Android ยป Launch app through adb shell

    Voila, calibration started and after doing the calibration I could use the device again.
    The problem now is that i have to recalibrate after each boot to be able to use the touchscreen. Pretty annoying

    I'm hoping someone can help me fix this, ideas and suggestions are more than welcome :)

    EDIT 110306:
    I've worked around the problem now by buying Launchafterboot by androgone development, so i'm now greeted by the calibration program after reboot.

    It feels kinda bad, not to be able to fix the situation, so any help would be appreciated.
     
    Last edited: Mar 6, 2011
  2. Ronny007

    Ronny007 Member

    Joined:
    Sep 9, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Germany
    Tablet / Device:
    PMT43Wifi
    Dear hoan,

    I have on question to the "Launchafterboot" app. How did you tell this app to launch AndroidCalibrate every time you reboot?

    Thanks Ronny007
     

Share This Page

Search tags for this page

imito im7 firmware flash adb

,

imito im7 win7 upgrade