Linux ADB trouble

Discussion in 'Huawei Ideos S7' started by SikYou, Dec 27, 2010.

  1. SikYou

    SikYou Member

    Joined:
    Dec 25, 2010
    Messages:
    180
    Likes Received:
    17
    Trophy Points:
    87
    Location:
    Detroit
    Tablet / Device:
    S7
    For some reason I can't get adb to recognize the s7 on my ubuntu machine, adb devices shows ??????? no permission. I have plenty of experience with adb and my other devies are working fine. I know I'm missing something simple but what? Thanks

    rooted, busybox installed, debugging on

    Sent from my Ideos S7
     
  2. fluxxion

    fluxxion Member

    Joined:
    Dec 8, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Wilmington/Cincinnati OH
    Tablet / Device:
    Huawei S7
    with it plugged in, try adb kill-server, then adb-start-server, then check the devices again and it should show up
     
  3. ivyvisors

    ivyvisors Senior Member

    Joined:
    Dec 29, 2010
    Messages:
    233
    Likes Received:
    52
    Trophy Points:
    102
    Location:
    melbourne
    Tablet / Device:
    huawai s7
    try the following.

    sudo ./adb start-server

    then use adb as normal.

    Sent from my Ideos S7 using Android Tablet Forum App
     
  4. SikYou

    SikYou Member

    Joined:
    Dec 25, 2010
    Messages:
    180
    Likes Received:
    17
    Trophy Points:
    87
    Location:
    Detroit
    Tablet / Device:
    S7
    Thanks guys I figured it out a couple of days ago. I just had to add my device path to .basrc, I knew it was something simple. Now I just plug, cd, and ./adb ;)

    Sent from my nonsensikal froyo
     

Share This Page