Major Brick/Stuck on CRUZ Logo on Start - T103

Discussion in 'Velocity Micro Tablets' started by Piggy, Dec 4, 2011.

  1. Piggy

    Piggy Member

    Joined:
    Dec 4, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Portland, Oregon, USA
    Tablet / Device:
    DROID Eris, Cruz Tablet T103
    Hi, I'm new here and have a question...

    My Cruz tablet (T103) is having a bit of a issue... when ever I try to start it up, it will start at the Cruz logo, and it won't go away. All the soft keys are touchable and light up on touch, but nothing else works... I have tried formatting my SD card and putting it back in, with no luck. I also have tried to boot into recovery mode, again without luck... it simply turns the screen black, but on (you can tell), and the soft keys, again, can light up. I'm not sure what is wrong with it, because using the reset hole just reboots the device, making it go through the same process. Can someone please help me here? Thanks.
     
  2. plasticv

    plasticv Member

    Joined:
    Dec 25, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    60
    the same problem
     
  3. mymaster32

    mymaster32 Member

    Joined:
    Dec 26, 2011
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    60
    Tablet / Device:
    Cruz Tablet T103
    I also have a T103 I love it got it for Christmas, trying to be helpful on forums.

    Here is my suggestions

    See if this works, if you can do it, not sure how far you can get.

    Go to settings, six lines in the middle of home button and back button.

    Then Privacy

    Then go to Factory Data Reset.

    Hope this works! Tell me.
     

Share This Page