MID 7015 Battery error

Discussion in 'Coby Generation 1' started by Delaney64, Mar 1, 2011.

  1. Delaney64

    Delaney64 Member

    Joined:
    Dec 27, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    70
    Tablet / Device:
    Coby Kryos MID 7015
    My battery says it was less than 5% when I turned it on so I plugged it in and 5 seconds later said it was around 77% charged. I do not believe that right lol.
     
  2. popeye1128

    popeye1128 Member

    Joined:
    Feb 14, 2011
    Messages:
    186
    Likes Received:
    16
    Trophy Points:
    87
    Location:
    Arkansas
    Tablet / Device:
    Coby MID 7015
    Does the charge light between the USB and HDMI connectors go from red to green? If you have CWM installed you can try wiping the battery history and see if that helps. Otherwise your battery may be hosed.
     
  3. l_n

    l_n Senior Member

    Joined:
    Dec 28, 2010
    Messages:
    788
    Likes Received:
    99
    Trophy Points:
    102
    Location:
    TN, USA
    Tablet / Device:
    Mid7015
    The battery percentages on the kyros are known to be wildly inaccurate. It's probably a cheap IC in the battery.

    Sent from my DROIDX using Tapatalk
     
  4. Delaney64

    Delaney64 Member

    Joined:
    Dec 27, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    70
    Tablet / Device:
    Coby Kryos MID 7015
    Yes the light is red when it needs to be charged and changes to green when its "fully" charged.
     
  5. chicle

    chicle Member

    Joined:
    Jan 30, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Florida
    Tablet / Device:
    Coby Kyros 7015
    While connected, go to market and download and install battery boost (I think that's the name. Its icon is a large green B). Unplug your tablet and allow the battery to completely drain. With the tablet off, connect the power until the red light turns green. Turn the tablet on and run battery boost. This fixed the battery problem on my Coby, hopefully it'll work on yours.

    Good luck.

    Sent from my sdk using Android Tablet Forum App
     

Share This Page