My wifi is connected but tablet is acting like I have no internet!

Discussion in 'Android Tablet Q&A' started by Aderdade, Jul 23, 2012.

  1. Aderdade
    Offline

    Aderdade Junior Member

    Joined:
    Jul 23, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Mississippi
    I have had this tablet for almost a year now. We got new internet service and I made sure that the password I entered was correct. The tablet show that I am connected but the Play Store will not load. Also, apps like Pandora, Netflix, and the Amazon App-store will also not load. Funny thing is that all of these apps will not work but my plain browser picks up the internet signal and I have limited ability to browse through there. But a error message pops up every few seconds. Please help! I love my tablet, but I think the new upgrade has messed it up!:(
  2. leeshor
    Offline

    leeshor Super Moderator Staff Member

    Joined:
    Dec 27, 2011
    Messages:
    4,758
    Likes Received:
    911
    Trophy Points:
    113
    Location:
    Norcross, GA

    Welcome to the forum Aderdade

    That's pretty strange and there are only very few explanations. I'd like to suggest you find a public hotspot and see if it works there to rule out your tablet but it sounds like the router is at fault.

    When you use the browser, what types of problems are you having? The Play Store and Amazon don't work well if you're behind a proxy server as they have difficulty identifying your device correctly. But that doesn't sound like the problem. It's also possible the new modem has a firewall that's blocking it.

    Not certain where to go from here other than what I have said, unless you can provide additional information.

Share This Page