No USB connection option with Cube U30GT

Discussion in 'Rockchip Based' started by spookydad, Jul 25, 2012.

  1. spookydad

    spookydad Member

    Jun 24, 2012
    Likes Received:
    Trophy Points:
    I have a U30GT - H and have already flashed to Evo Prime 1.3. It was a bit of a bumpy ride as I ended up having to do a hardware reset after disassembling the unit. When I disassembled it I discovered a poor solder connection on the battery wires. It was getting intermittent power so when it shut down during the flashing process, it ended up bricked. All is fine now except for one problem, when I connect the USB cable to my PC, I don't get the option to mount the USB storage. I have tried reinstalling the drivers, but no luck. This is the same machine that I flashed it on, so I know it isn't a cable or hardware issue. I have tried the included cable and the one that came with my Samsung SG2.

    Out of desperation, I tried the PDA net program and that works fine.

    Any suggestions?
  2. Dawnstar

    Dawnstar Senior Member

    Sep 5, 2012
    Likes Received:
    Trophy Points:
    United Kingdom
    Tablet / Device:
    Samsung GalaxyTab2

    I can help you on your question (when I connect the USB cable to my PC, I don't get the option to mount the USB storage)

    1. Turn off the Cube then plug in the mini USB cable then connect to PC/Laptop 2. Then on the (Cube) Hit the power and vol + button at the same time. Then when you hear a beep on the pc let go of both buttons on the tablet wait for the PC to update the driver 3. then on your Cube screen it will show the USB icon for you to turn on. that's it done

    All you do next time is make sure your tablet is off, 1. Then plug in the USB cable and connect to the pc 2. Then turn on the Cube power button (Only) Then wait to see (USB icon) on the (Cube screen) Touch it to turn it on.....Done.

    This worked on my Windows 7 (64bit) PC:D
    Last edited: Sep 7, 2012

Share This Page

Search tags for this page

cube u30gt driver windows 7

cube u30gt mini driver download
how ro hard reset tablet u30gt
problem mounting usb u30gt
u30gt usb driver