Progress with Coby Kyros MID1024

Discussion in 'Coby Generation 2 Technical' started by cfirpo99, Sep 12, 2011.

  1. cfirpo99

    cfirpo99 Member

    Joined:
    Sep 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    60
    Tablet / Device:
    Koby 1024
    I just wanted to recap what I have done with my tablet and I'm looking for some direction with the market not letting me download a lot of apps. I'm getting "this device is not compatible with this item". for apps like google maps and facebook.

    The market must be reading a signature on the tablet because on the actual market website it shows up as a "T-mobile mid1024", and says incompatible with app.

    I found a post in the market help stating it is due to the screen size and or OS version...? So I dont think its the OS version because 2.2 pretty standard for most apps.

    There has to be a way to get around this.

    So far I have done the following:
    rooted with superoneclick 2.1.1
    installed android market 3.1.3

    I haven't played around with clockworkmod as I read that this will brick the device. XDA mentions formatting the cache partition but i dont think that it applies to this device.

    Thanks..
     
  2. lfom

    lfom Senior Member Developer

    Joined:
    Sep 12, 2011
    Messages:
    1,387
    Likes Received:
    240
    Trophy Points:
    162
    Location:
    Brasil
    Same happened here... If you roll back to Market 2.x it won't complain and you should be able to install most apps. Remove or disable the updater apk (if you have installed it too) to prevent it to self-update.

    Cheers
     
  3. cfirpo99

    cfirpo99 Member

    Joined:
    Sep 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    60
    Tablet / Device:
    Koby 1024
    Thanks I will give that a try. I had initially loaded the old market, (green/white splash), and I didn't even bother to test it out. I went to the next version, and they simply blocked out the download button on some apps, and then on 3.1.3, you get the incompatibility message.
    I will give the old one a try..

    Have you had any luck installing GAPPS, google services framework APK? i just tried to install the apk without any prior mods and install fails. i do see a framework dir on the device, but not sure how to mess around with it.

    Also, were you able to back up your config just in case something goes wrong?

    Thanks..
     
  4. cfirpo99

    cfirpo99 Member

    Joined:
    Sep 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    60
    Tablet / Device:
    Koby 1024
    Awesome, that was it. I went with market version 2.3.6

    No problems so far.

    Sent from my MID1024 using Android Tablet Forum
     
  5. lfom

    lfom Senior Member Developer

    Joined:
    Sep 12, 2011
    Messages:
    1,387
    Likes Received:
    240
    Trophy Points:
    162
    Location:
    Brasil
    Cool. Could you please make the files that you've used available somewhere?

    AFAIK one has to install GoogleServicesFramework before installing Vending.apk, reboot and it should work, that's what I have read elsewhere. But now I am stuck with a Force Close in the GAPP service and can't get through it (that's why I didn't reply earlier). =(

    edit: crash fixed. I mistakenly deleted ContactsProvider.apk from /system/app breaking GAPP service, putting it back fixed it.
     
    Last edited: Sep 13, 2011
  6. cfirpo99

    cfirpo99 Member

    Joined:
    Sep 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    60
    Tablet / Device:
    Koby 1024
  7. anatiti

    anatiti Member

    Joined:
    Sep 13, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    60
    Ok, I got mine rooted np but can't make the market work. It installs but wont start! Tried different .apk still the same.
     
  8. lfom

    lfom Senior Member Developer

    Joined:
    Sep 12, 2011
    Messages:
    1,387
    Likes Received:
    240
    Trophy Points:
    162
    Location:
    Brasil
    You must install GoogleServicesFramework first and only then the Vending apk (Market itself), reboot the tablet and open Market. GServices is needed to bind your device to your Google account.
     
  9. lfom

    lfom Senior Member Developer

    Joined:
    Sep 12, 2011
    Messages:
    1,387
    Likes Received:
    240
    Trophy Points:
    162
    Location:
    Brasil
    Could someone please also post the GettingStarted.avi in English somewhere so I can download it? Thanks in advance. ;)
     
  10. cfirpo99

    cfirpo99 Member

    Joined:
    Sep 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    60
    Tablet / Device:
    Koby 1024
    lfom, in general when installing APK's do they need to be in the target directory before executing, in our case /system/app? I was able to run them from pretty much anywhere but maybe this is not best practice.

    I also noticed that the device comes with this following structure:
    /system/framework/vending.apk (which I will never touch again)
    and
    /system/app
    calendar
    sync
    etc..

    So when you install gapps, does it just coexist with the coby version of these apps like sync and calendar?
     

Share This Page

Search tags for this page

coby mid1024 android update

,
google map service framework coby
,
updated system calendar for mid1024