[ROM][6.0.1] Unlegacy Android 6.0.1/Lineage-13.0 For A2109 [2017-05-28]

Discussion in 'Lenovo IdeaTab A2109 Development' started by PJBrs, Dec 4, 2016.

  1. Deleted member 217101

    Deleted member 217101 Guest

    Top Poster Of Month

    I didn't do a full wipe when I flashed and had problems with Play Games crashing. I uninstalled and reinstalled the app and that has fixed the issue so far.
     
    • Like Like x 1
  2. joebine

    joebine Senior Member

    Joined:
    Jan 14, 2015
    Messages:
    150
    Likes Received:
    32
    Trophy Points:
    210
  3. profeet

    profeet Senior Member

    Joined:
    Aug 17, 2014
    Messages:
    42
    Likes Received:
    7
    Trophy Points:
    180
    Location:
    Ukraine
    Tablet / Device:
    A2109
    I made dirty flash new version (22.08) on previous (08.08), gapps & magisk don't started, i reflash it from twrp.
    After boot, YouTube, Gmail & search fs, reinstall it from play store, works fine for now.
    Changes: new core & security patch August.

    System freezes randomly
    Thanks @PJBrs
     
  4. joebine

    joebine Senior Member

    Joined:
    Jan 14, 2015
    Messages:
    150
    Likes Received:
    32
    Trophy Points:
    210
    With the new build (2208) I don't have deep sleep...
     
  5. joebine

    joebine Senior Member

    Joined:
    Jan 14, 2015
    Messages:
    150
    Likes Received:
    32
    Trophy Points:
    210
  6. PJBrs

    PJBrs Senior Member Developer

    Joined:
    Dec 29, 2014
    Messages:
    480
    Likes Received:
    405
    Trophy Points:
    340
    Thanks for all the testing!

    The new builds that you're seeing are the automated tests from the Unlegacy build system. I haven't gotten around making a first post for nougat yet. Also, I haven't been able to even try and fix the two bugs (wireless display, screen recorder) since my PSU died, grrrrr!
     
    • Like Like x 3
  7. yaka

    yaka Senior Member

    Joined:
    Jun 28, 2015
    Messages:
    30
    Likes Received:
    11
    Trophy Points:
    180
    Location:
    Hungary
    Tablet / Device:
    Lenovo A2109
    Dear PJBrs, you disappeared for quite some time... I was a bit worried! Nice to have you back! :)
     
    • Like Like x 2
  8. joebine

    joebine Senior Member

    Joined:
    Jan 14, 2015
    Messages:
    150
    Likes Received:
    32
    Trophy Points:
    210
    So the only build, on the Unlegacy site, that is yours is the experimental?

    If so, I will get back to that build...
     
  9. PJBrs

    PJBrs Senior Member Developer

    Joined:
    Dec 29, 2014
    Messages:
    480
    Likes Received:
    405
    Trophy Points:
    340
    Holidays, eh! :)

    Uhmm... Well, I'm part of the Unlegacy team now, so in that sense they're all mine? I'd say, the newer the better, but I'll let people know when I fix some bug. Also, this still is a good place to report your issues. I had a private build of Lineage as well, but I'm not very interested in maintaining that...
     
    • Agree Agree x 1
  10. Tattmann

    Tattmann Member

    Joined:
    May 16, 2015
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    78
    Hey, I have a bit of a problem. I have installed the ua_a2109-7.1.2-20170918095805 rom, and flashed in gapps 7.1 pico. However, when booted it begins asking to setup the tablet. When I get to the second screen asking me to setup a new device or transfer from cloud, I click set up as new. The setup stops with a "setup wizard has stopped" message. I click open app again, it repeats. I went back to cwm and factory reset it, it still stops. for now I guess I will go back to lineage-13.0-20170528-UNOFFICIAL-a2109. It loads and works well enough.
     
  11. yaka

    yaka Senior Member

    Joined:
    Jun 28, 2015
    Messages:
    30
    Likes Received:
    11
    Trophy Points:
    180
    Location:
    Hungary
    Tablet / Device:
    Lenovo A2109
    You should download the newest GAPPS 7.1 pico (your problem is because your GAPPS is older than your ROM).
     
    Last edited: Sep 21, 2017
  12. Tattmann

    Tattmann Member

    Joined:
    May 16, 2015
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    78
    Thank you for taking the time to reply. The rom looks dated to the 18th, and the gapps I downloaded yesterday from the open gapps site, I suppose they could be a little older than the rom if they didnt post the newest set, I will wait a few days and download another set. in the meantime I will download the previous build of the rom and see if the gapps work with the previous rom. I HAVE had a problem once a couple years ago on my s5 where the gapps simply would not work at all. Anyway, thanks again for replying.
     
  13. Tattmann

    Tattmann Member

    Joined:
    May 16, 2015
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    78
    Update to my last post, That didnt work. I tried yesterday on one tablet, today on another. Tried 3 different 7.1 roms, and 2 different 7.1 pico downloads. Still not working. Between roms I did factory reset wipes, but end result was the same. I went as far back as the 7-25-2017 build, tried the 9-14-2017 and the 9-14-2017 builds all with the same result. Setup wizard has stopped message on all 3 rom versions with 2 different pico 7.1 builds. These were all flashed from cwm 6.0.5.1, does anyone have any ideas as to why this is not working in either of the a2109 tablets I have?

    Update:

    I was able to get 6.0 installed from 8-26-2017, it installed fine, and loaded up perfectly. I just dont understand why I cant get the nougat versions to work. Anyway, until I get a working rom I will stick on the 6.0. It looks very nice.
     
    Last edited: Sep 21, 2017
  14. yaka

    yaka Senior Member

    Joined:
    Jun 28, 2015
    Messages:
    30
    Likes Received:
    11
    Trophy Points:
    180
    Location:
    Hungary
    Tablet / Device:
    Lenovo A2109
    Did you install the 7.1 ROM and the GAPPS right after one another, without booting the ROM first?
     
    • Like Like x 1
  15. Tattmann

    Tattmann Member

    Joined:
    May 16, 2015
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    78
    Yes I did, I will try booting on just the rom first and reboot, then flashing gapps

    Update:

    That WORKED!! Thank you very much! I really appreciate it.
     
    Last edited: Sep 21, 2017
    • Like Like x 1

Share This Page

Search tags for this page
cm13 a2109
,

how to fix video playback and recording on lineage 13

,
how turn on zram on lineage
,
lenovo ideapad a2109a lineageos
,
lenovo ideatab a2109 android 6
,
linaeage 14 lenovo a2109
,

lineage 14 a2109

,
lineage 14 lenovo a2109
,
lineage 14 lenovo a2109a
,
tinyplay cm13