[ROM][7.1.2] Unlegacy Android 7.1.2 (Nougat)

Discussion in 'Lenovo IdeaTab A2109 Development' started by PJBrs, Oct 5, 2017.

  1. scissors99

    scissors99 Member

    Joined:
    Jun 25, 2016
    Messages:
    39
    Likes Received:
    9
    Trophy Points:
    90
    Hi,
    I think the original experiment build was ok, but I too think the others have been sluggish.
    I just dirty flashed the 19th Oct build and the same.
    Things like opening an app, stuttering. Play store up date app, takes ages. just a general sluggishness (like before the 6.xx builds)
     
  2. PJBrs

    PJBrs Senior Member Developer

    Joined:
    Dec 29, 2014
    Messages:
    471
    Likes Received:
    390
    Trophy Points:
    340
    Hmmm.... Might be, I noticed some too, but then again, my kids have been adding games. Also, I dropped a glass jar of jelly on my second tablet, so that one's severely out of order.

    In the meantime, I'm focusing on security issues right now. Unlegacy team members are working on Oreo.
     
    • Like Like x 2
  3. PJBrs

    PJBrs Senior Member Developer

    Joined:
    Dec 29, 2014
    Messages:
    471
    Likes Received:
    390
    Trophy Points:
    340
    There's a new build out with various kernel patches. It should make some difference. I'd like to hear whether the sluggishness has diminished. Please test with cache and dalvik cache wiped.
     
    • Like Like x 2
  4. rsvtoddy

    rsvtoddy Senior Member

    Joined:
    May 21, 2013
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    170
    Location:
    United Kingdom
    Tablet / Device:
    Samsung 3110
    Many thanks - just installed the new build and wiped caches as suggested. It does feel a bit snappier but I hadn't had any problems before. I will update later as I use it.

    Great job!

    Sent from my A2109A using Tapatalk
     
    • Like Like x 1
  5. de1

    de1 Junior Member

    Joined:
    Nov 4, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    22
    Hi, thanks for providing it. I just tried to install it (ua_a2109-7.1.2-20171102085214)
    . I wiped everything before.
    But I just can't get passed the first setup page:
    - Clicking on "Let's go"
    - selecting country
    - Select "setup as new" (popup)

    Setup Wizard crashes.

    Any ideas?

    EDIT: I've installed the latest 6.0.1 build of ua and that was fine (both with gapps)
     
    Last edited: Nov 4, 2017
  6. PJBrs

    PJBrs Senior Member Developer

    Joined:
    Dec 29, 2014
    Messages:
    471
    Likes Received:
    390
    Trophy Points:
    340
    Hmm... I can't think of anything right away... Did you also wipe cache and dalvik cache? Did you install gapps, and if so, did you do so immediately after installing the rom, without rebooting?
     
  7. de1

    de1 Junior Member

    Joined:
    Nov 4, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    22
    Yes, certainly cached all those and flashed gapps immediately after the ROM. The first time I didn't clear data. It then was slightly different but the setup still crashed. I then went through the whole process again but clearing data as well. The same process for the 6.0.1 worked (with different version of gapps). I'll keep that for now.
     
  8. RoachTheHorse

    RoachTheHorse Member

    Joined:
    Jun 29, 2017
    Messages:
    11
    Likes Received:
    6
    Trophy Points:
    45
    I am facing exactly the same issue. Tried flashing both Pico and nano gaps, but only the first worked. Couldn't get passt the "let's go" screen. I managed to open the settings (by frantically swiping the notification bar) and managed to connect the tablet to my WLAN. That somehow stopped the configuration assistant from crashing, but funnily non of the Google apps were installed. I am facing the same issue with the latest 6.0.1 unlegacy build. Any ideas?

    Sent from my F5321 using Tapatalk
     
  9. de1

    de1 Junior Member

    Joined:
    Nov 4, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    22
    I tried:

    * ua_a2109-7.1.2-20171102085214.zip with open_gapps-arm-7.1-pico-20171104.zip - not working
    * ua_a2109-6.0.1-20170916175354.zip with open_gapps-arm-6.0-pico-20171104.zip - which was fine
     
  10. RoachTheHorse

    RoachTheHorse Member

    Joined:
    Jun 29, 2017
    Messages:
    11
    Likes Received:
    6
    Trophy Points:
    45
    Thanks for the feedback. I flashed the ROM you recommended followed by the newest pico Gapps. I had no issues to configure the tablet. The wizard did not crashed. I let the tablet alone a couple of hours to do what it had to do.

    Following I rooted the thing and installed SSD Boost from the play store. I had the feeling that after many years of usage and flashing and re-flashing ROMs, the eMMC could be "out of shape". I have to say that the tablet is quite responsive. My guess is that SSD boost made a TRIM on the eMMC and tuned a couple of things more. Additionally I installed Greenify with root permission and by now the A2109 flies. It is not a Nvidia Shield, but it is pretty damn usable!

    Again, thanks to the developer, and for those experiencing sluggishness try rooting and letting SSD Boost do its magic. If you do, give the app some time. The first time it requires several minutes to work.

    Sent from my A2109A using Tapatalk
     
  11. RoachTheHorse

    RoachTheHorse Member

    Joined:
    Jun 29, 2017
    Messages:
    11
    Likes Received:
    6
    Trophy Points:
    45
    I just wanted to update how the tablet behaves. Yesterday I used the tablet until the battery run out empty. I charged it during the night and started the tablet again today in the morning. At first it was extremely sluggish, but after some time it returned to normal. SSD Boost seems to run after every reboot, which might explain why the tablet was sluggish.

    As a side note, I ran some SNES and GBA emulators yesterday, some HD videos on YouTube and a lot of gaming (Hambo, awesome game) and the tablet managed it like a champ. From time to time a small freeze, but not a deal breaker. Still happy with the performance.

    Sent from my A2109A using Tapatalk
     
    • Like Like x 1
  12. kin-kwok

    kin-kwok Member

    Joined:
    Feb 14, 2016
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    78
    Hi PJBrs,

    I have tested the latest Unlegacy ROM over the weekend (2017-11-30 version). The following is what I found.

    Everything work fine with GApps Pico, the only problem is it will FC at the initial setup. The wifi was not enable at the first boot. I have to use the following ADB CLI (adb shell am start -a android.intent.action.MAIN -n com.android.settings.wifi.WifiSettings) to bring up the wifi setting to enable the radio. Not sure you can modify the ROM to have the wifi enable at the first bootup. I believe the BT was enabled at first boot.

    The "split screen" is working fine when I do clean install with or withou GApps. It stops working after I installed SuperSU. Not sure what causes it.

    The only question I have is the "user profile" configure is disabled. I cannot create a "restricted user" for my kid. I think it was available on CM.


    Great works, thanks.


    KK
     
    • Like Like x 1
  13. yaka

    yaka Member

    Joined:
    Jun 28, 2015
    Messages:
    27
    Likes Received:
    11
    Trophy Points:
    80
    Location:
    Hungary
    Tablet / Device:
    Lenovo A2109
    Awsome. Your team members are aware of Android Oreo Go Edition, right?
     
  14. rocksolid87

    rocksolid87 Junior Member

    Joined:
    Dec 5, 2017
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    2
    I tried the latest image file. Installation went fine, but I couldn't get past the welcome screen. Regardless of whether I clicked on mirror another device or start fresh it would give me an error message that the app has crashed and would take me back to the same welcome screen. I couldn't go any further.

    Any solution for this?
     
  15. PJBrs

    PJBrs Senior Member Developer

    Joined:
    Dec 29, 2014
    Messages:
    471
    Likes Received:
    390
    Trophy Points:
    340
    I'll see whether I can do something about the startup wizard not bringing up wifi...

    BY THE WAY - a logcat of the crash would be very helpful!
     
    Last edited: Dec 9, 2017

Share This Page

Search tags for this page
for acer a 500 nougat os rom
,
acer a500 nougat
,
acer a500 nougat download
,

acer a500 nougat rom

,
acer iconia a500 nougat
,
nougat root administration shell account
,
skip android setupwizard