Rooting ONDA VX580W

Discussion in 'Rockchip RK2818 Tablets' started by Headcrash77, Aug 6, 2012.

  1. Headcrash77

    Headcrash77 Member

    Aug 6, 2012
    Likes Received:
    Trophy Points:

    I recently got an ONDA VX580W MP4 Player and Have been trying for days now to Root the device, without any luck.


    OS: Android2.2
    CPU Speed: 660MHz
    CPU: RK2818
    RAM: 256MB DDR2
    Memory Size: 8GB
    Support Card: Micro SD(TF),32GB
    Screen Size: 5 inch
    Resolution: 800×480
    WIFI: 802.11b/g/n
    3G: Yes
    G-sensor: Yes
    Video Format: AVI, RM, RMVB, PMP, FLV, MP4, M4V, VOB, WMV, 3GP, MKV
    Video Resolution: 720P, 1280 ×7 20
    Audio Format: MP1, MP2, MP3, WMA, OGG, APE, FLAC, WAV, AC3, AAC, AMR, DTS, RA, M4A
    Picture Format: JPG, BMP, PNG, GIF
    File Format: PDF, TXT, EPUB
    E-book: Aldiko, Adobe Reader
    OTG: Yes
    USB: USB2.0

    Methods I Have tried:

    I have searched countlessly for Specific Onda VX580W related information, and most i have found relates to the other version of the model with the "AllWinner" chip, so that was useless to me.

    I did however find some info on this China Digitals. (if you wish to see it, search "Chinese digitals onda vx580w rk28xx custom rom"

    But when I used the necessary programs to flash the device (and the software said it was successful). My device just sat there with a black screen. (and I did wait quite a while) Fortunately, It was still able to connect via USB so i was able to RE-Flash the device with the original .img from ONDA's website.

    There was also another topic mentioned in that China Digitals post (The one reffering to MP4Nations), which also stated to have Rooted firmware compatible with my device, however this had the same results. At the time, I was pretty mortified, since I thought that I had bricked my device TWICE.

    (And i have tried Registering on China Digital forum to ask them about it, but it requires the Administrator to Verify accounts, rather than via verification email, so I'm unable to ask, since its been several days now and vie still had no verification.

    I did try the image from the Original China Digitals post ONCE more, but again, black screen, and nothing. So I restored it to its original state once again.

    I have also tried, these Apps, directly on the device:

    z4root ~ No success.
    Universal-1-click-root ~ No success either.
    GingerBreak (Latest) - No Success

    I have also tried using the software Super One Click. (and I also tried this after having installed Java JDK and Android SDK)

    Most of the time it just freezes (Not Responding) after getting to
    "step 2: Starting ADB Server"​
    , OR it gets all the way to "Check if Shell Rooted Step#3" and then stops responding. I have also tried this on 3 different computers, 2 being 64bit, the other being 32bit. (All windows 7).

    After trying all that with still no success, I'm at a loss of what to do next, I would very much like Root access so I can remove the useless Chinese Apps that take up memory that i'll never use and always seem to be running.

    I've heard that you can unpack the Update.img for the ROM and modify it to have Root access (and remove the unnecessary apps) and then repack it, xaueious posted some tools for unpacking UPDATE.IMG files, and ive taken the official Onda Firmware (from Onda's site) and unpacked it. But i'm unsure of what to do next to Root the device (i think i need to modify the system.img), and remove the unwanted bloat apps.

    Also while im on the subject of modifying the ROM, the device does have a tenancy to lock up and slow right down, I've heard there may be ways to improve performance.

    If anyone could help out or point me in the direction of what to do next to root this device, i would be very greatful. (and Im using Windows 7, so if anyone posts some instructions, they'd have to be for CMD rather than Linux Terminal (since ive seen a few topics that have various instructions, but all seem to be for linux terminal).

    Last edited: Aug 6, 2012

Share This Page

Search tags for this page

apps for onda vx580w


how to unlock onda vx580w


onda vx580w rooting