Southern Telecom Slick Websurfer Tablet

Discussion in 'Android Tablet Q&A' started by Galo, Mar 21, 2012.

  1. Galo

    Galo Member

    Joined:
    Mar 21, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    242
    Hi all! Thanks for viewing and possibly assisting. My sis bought me this tablet (Southern Telecom Slick Websurfer Tablet Android 2.1 )and I was wondering if anyone has it or had some experience with it because I am experiencing some boot issues. I tried to research and I really couldn't find ANYTHING on it. Well what happens is, when I turn it on by power button, it shows the brand bootscreen (slick) then 4 seconds later it shows a screen that says " Internet WebSurfer" and thats it! It doesn't boot into anything else... It just stays on that screen. I tried charging it, It charges fine. I tried pressing other buttons but to no avail, I got no responses. I even tried double pressing power + home button and still NOTHING. I Also tried to attach it to my mac and nothing still. What do you guys think is wrong? Can you assist me please, if possible.

    THANK YOU!
     

Share This Page

Search tags for this page

slick tablets

,
slick websurfer internet tablet
,
southern telecom tablets
,
websurfer android tabet