Touchscreen not responsive (ZT280 C91 1a)

Discussion in 'Zenithink ZT280 C91 & C91 Upgrade' started by stephenzenithink, Aug 22, 2012.

  1. stephenzenithink

    stephenzenithink Member

    Joined:
    Aug 22, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    60
    Tablet / Device:
    Zenithink ZT280 C91 1a
    Hi all,

    I have a Zenithink ZT280 C91 1a, for a couple of days the tablet worked OK except when the battery went below 75% the screen would not turn on unless the charger was plugged in.

    I upgraded to the latest software which was ok for a short period of time, the battery reduced below 60% and the screen again would not turn on unless the charger was plugged in, I tried to flash the software again and the screen became totally unresponsive.

    I then tried an alternative Rom Zenidroid but the screen remained unresponsive, I have since returned to the official software but again the screen is still not working.

    Has anyone else experienced this and if so what did you do to fix it?
     

Share This Page