trouble with Pantech Element

Discussion in 'Android Tablet Q&A' started by nettie2, Apr 22, 2012.

  1. nettie2
    Offline

    nettie2 Junior Member

    Joined:
    Apr 22, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Maine
    Hi, I've had my Element for almost two months and have had a problem with it shutting itself down without any warning. First time was when I was playing a game.Happened again yesterday when doing a recipe search.It just goes blank and won't turn on. The first time,I waited a day,charged it and it seemed to be ok. Today,I have tried to plug it in,but will not turn on!This is getting to be very frustrating...do I have a bad tablet?Is there a way I can fix it? Am ready to take it back to the AT&T store.
  2. RobRoy
    Offline

    RobRoy Junior Member

    Joined:
    May 24, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    So Cal
    Nettie: We bought two (2) Pantech tablets three months ago. One failed immediately, another three weeks later. This week while I was on business travel and actually trying to keep up with life, the same problem occurred.

    I just walked in from the ATT store where the guys were on the phone to the Pantech Hotline and in-parallel the Customer service rep plugged mine in. It restarted, but I asked him how he did that. He said ( and of course no one tells you this) that you can re-boot the Element by pressing the power button and the volume button simultaneously.

    Afterwards ( after I told them it was charged by the Pantech charger - not a substitute) and that I had a 32GB men module in it, they challenged both a charger fault and a faulty (system) S/W upload - neither of which are plausible failure mechanisms ( as the Pantech does not boot from the mem mod and the charger worked not only on my Pantech phone, but also on my Blackberry.

    So the discussion went to a "Well they can go to sleep at the 30% batt level" and it takes a reboot ( described above) to bring it back to life.

    ...at which time I asked why the hell don't they put some real basic operations ( such as if a reboot MAY BE required under SOME circumstances).

    So... FWIW (given a month later response) if it happens again, give that a try after charging. Good luck...

Share This Page