WiFi disconnects in sleep mode after JB update

Discussion in 'Asus TF201 Forum' started by oli1986, Nov 10, 2012.

  1. oli1986

    oli1986 Member

    Joined:
    Nov 10, 2012
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    62
    Location:
    Austria
    Tablet / Device:
    Asus Transformer Prime TF201
    hey,

    After the update to JB i have noticed that my tablet is disconnecting WiFi. I have checked every option (WiFi advance options, power saver options), I did a factory reset several time, I have checked it on 2 different routers but it is still disconnecting the WiFi when it goes in the sleep modus although the battery usage shows that wifi is always on. Does anyone have the same problem, found a solution for it?
     
  2. leeshor

    leeshor Senior Member

    Joined:
    Dec 27, 2011
    Messages:
    6,331
    Likes Received:
    1,037
    Trophy Points:
    700
    Location:
    Norcross, GA
    Tablet / Device:
    Samsung Galaxy Tab S 10.5
    Welcome to the forum

    In settings - ASUS customized setting - make certain that the disconnect network is unchecked, (last item) If that eats your battery go to the Store and install Auto Airplane Mode, (by DON)

    On the other hand, if when you set your TF back up after the factory resets you allow it to sync with Google and all the apps installed, again, it may be one of the apps causing the problem.
     
  3. oli1986

    oli1986 Member

    Joined:
    Nov 10, 2012
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    62
    Location:
    Austria
    Tablet / Device:
    Asus Transformer Prime TF201
    I need the WiFi to be always on because I want to know when I receive new messages. I've already checked every option: wifi "always on", disconnect network "unchecked", power saver "unchecked". I didn't use account/app sync or restore - only factory apps are installed on the tablet at the moment but the problem remains.

    Edit: Battery usage is not my problem - but I don't understand why it is disconnecting the network although wifi is set up to be always on and even the battery diagram shows that it is on
     
    Last edited: Nov 10, 2012
  4. leeshor

    leeshor Senior Member

    Joined:
    Dec 27, 2011
    Messages:
    6,331
    Likes Received:
    1,037
    Trophy Points:
    700
    Location:
    Norcross, GA
    Tablet / Device:
    Samsung Galaxy Tab S 10.5
    I know that if I want my TF to stay on WiFi I don't have a problem so you may want to take a close look at your router settings. I have some tips in a link below that may help.
     
  5. oli1986

    oli1986 Member

    Joined:
    Nov 10, 2012
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    62
    Location:
    Austria
    Tablet / Device:
    Asus Transformer Prime TF201
    Ok, I have checked your tipps in the link - the tablet is using channel 1, I checked the routers firmware and the encryption is wpa so every thing seems fine. I have downloaded a wifi fixer app on my TF and have noticed that when the tablet is coming out from the sleep mode the log of this application says "weak wifi signal" and than the network reconnects and the signal is strong. Do you have any other suggestions?
     
  6. leeshor

    leeshor Senior Member

    Joined:
    Dec 27, 2011
    Messages:
    6,331
    Likes Received:
    1,037
    Trophy Points:
    700
    Location:
    Norcross, GA
    Tablet / Device:
    Samsung Galaxy Tab S 10.5
    See if the same thing happens if you disable the security on your router temporarily.
     
  7. oli1986

    oli1986 Member

    Joined:
    Nov 10, 2012
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    62
    Location:
    Austria
    Tablet / Device:
    Asus Transformer Prime TF201
    Leeshor -it seems you have found the problem! With disabled WPA the network stays connected! :D Thanks you!!!
    Now the question, where should I make changes so it stays connected when WPA is active?
     
  8. leeshor

    leeshor Senior Member

    Joined:
    Dec 27, 2011
    Messages:
    6,331
    Likes Received:
    1,037
    Trophy Points:
    700
    Location:
    Norcross, GA
    Tablet / Device:
    Samsung Galaxy Tab S 10.5
    I don't have much of an answer for that one. I guess you could restart the router and try the WPA again. I do know that the chipset in the Transformers doesn't like WEP very much and that would be a poor choice anyway. Try whatever else may be available or a different WPA like preshared or something.

    Glad you're narrowing it down.
     
  9. oli1986

    oli1986 Member

    Joined:
    Nov 10, 2012
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    62
    Location:
    Austria
    Tablet / Device:
    Asus Transformer Prime TF201
    I think I've found the solution. I've set a static IP instead of DHCP and it seems to work fine. Thanks for your help.
     
    • Like Like x 2

Share This Page

Search tags for this page
acer iconia tab android wifi fail after sleep
,
android tablet disconnects wifi sleep mode
,
androoid tablet disconnects from wifi in sleep mode
,
asus tablet disconnects wifi
,
asus transformer prime wifi disconnect
,
my asus android tablet disconnects the wireless neytwork when it sleeps
,
my tablet keeps disconnecting from wifi after going to sleep
,
no wifi after sleep androd tablet
,

tablet android sleep problem

,
tablet disconnect wifi when sleep
,
tablet disconnects from internet
,
tablet disconnects from wifi on sleep with no power option tab
,
tablet disconnects from wifi when sleep
,
tablet setting disconnect wifi during sleep
,
tablet wi-fi disconnects when tablet sleeps
,
why android tablet loose wifi when sleep mode
,
why does my samsung tablet constantly disconnect
,

why does my samsung tablet keep disconnecting from wifi

,
why wifi disconnects frequently in tab
,
wifi disconnect in sleep android