Zenithink Tablet won't Power Down!

Discussion in 'Zenithink ZT280 C91 & C91 Upgrade' started by amcnguy, Mar 5, 2013.

  1. amcnguy

    amcnguy Member

    Aug 27, 2012
    Likes Received:
    Trophy Points:
    Tablet / Device:
    zenithink ZT-280 C-91
    Hi everyone, We have ZT-280, C-91 Tablet...running gingerbread 2.3.4...I think. Our problem.....the table won't power down! We cannot shut it off with pressing the power button, for any length of time! I did a reset a couple of times with a paper clip. Still no good! So...we have to leave it on until the battery is depleted. I plug the charger in and it comes on and charges fine. But, the software shutdown screen will not show, when pressing power button.
    I did find an Android "shut down/re-start" app, but the Tablet needs to be Rooted to use it. Which brings me to my second question. Has anyone found a 1 click rooting app which our ZT-280's respond to? I haven't tried it yet, but was reading where they're is Z4-root, Gingerbreak, Super one click, & some others. I'm kinda new to these tablets, and don't want to "Brick" it as they say!
    Thank you!

Share This Page