Adding Play Store To Tablet


Senior Member
Feb 14, 2013
A friend of mine recently got an Emerson EM743 tablet. While not new, it was free, so there's that.

While playing around with it, she found it didn't have the Play Store, so she brought it to me. Usually, I can find ways around that.

The first thing I did, of course, was to actually download the Play Store. It unfortunately gives the "Unfortunately, Google Play Store has stopped." message as soon as you try loading it. And yes, I do have "Unknown Sources" checked, so I can run apks that don't come from the store.

My next thought was to check the Google Play Services. It's running 4.1.1, with v7a architecture, and 480 dpi. That means, as far as I can tell, I need a Google Play Services that ends with "-038". Unfortunately, the one installed simply said "0". Doing a little looking around, I found one on apkmirror and loaded it. That, in theory, should be all I need, but I still get the same error message.

What did I miss? Did I get something wrong somewhere along the way?