Am I this unlucky?

Haiko

Member
Sep 7, 2012
1
0
I bought a tablet from this site early July on a deal which was posted on slickdeal. I had received the tablet a week later in excellent condition and was thrilled since it was my first tablet i ever owned.
I charged it right away since it said so on the manual and waited 2-3 hours till i get to have fun with it. It worked flawlessly and was happy for the purchase till the next day. When i turn on the tablet the next morning it turn on for a few sec then the tablet itself turn off for no apparent reason...I tried to press the power button again but no picture was showing and yet i keep hearing the tabbing sounds when i hit the screen. I hit up customer service since i had no clue whats wrong with it and this is what they told me >_>
me to them
Item: 7 Inch AllWinner A13 1.5GHz Android 4.0 Tablet PC 512MB RAM 4GB McPad F1 Capacitance screen WIFI Camera Black (CP147739) Item code: 147995

I only had this tablet for 2 days till the screen died on me. I thought it was the battery at first so i left it to charge all night and tried it this morning and still the dispay not responsive. I can hear it running and it was able to connect with PC but no picture =( please help and thank you.




their response

Please take a video for the problem you are talking,we want to check it. and you can try the following method:

1 find a hdmi cable;
2 connect the tablet with the TV;
3 check if there is image on TV

are you setting the screen brightness to darkness?


Please don't worry, if we find the problem is caused by our product, you can send it back for a replacement, and we will handle the shipping cost to you.



anyway, send us some video to confirm.



>My tablet doesnt have HDMI out >_>

They wanted me to install some firmwire in which i did...didn't do **** >_>
bouncing back email to email telling me it was the firmwire issue even though i know the tablet is defective....

Hello Haiko
I think you need to reboot
here is the link
http://www.szampe.com/UploadFile/file/2011-08/0157.rar
and I have send you the video.
please check .
thanks!

3 different firmwire and I kept telling them that i just want an replacement...
me to them

Ok i manage to install the new update or firmwire to the tablet but it didnt do nothing about my screen issue. I'm pretty sure this is a defective tablet and I really want you guys to help me resolve this issue by giving me a replacement or an refund. Thank you.

another email saying to install another firmwire...what the **** man...

I installed the new firmwire you sent me and it installed fine but display showing nothing again which im 100% sure this is a defective tablet...your website states that i have warranty so i can i get an replacement if not a refund...thank you//

their response


are you sure you have make reboot Success?another way ,you can put light on the screen ,you can see the inner button of the tablet ,then you can make the Brightness up.

if can't solve it .please return back .

I have send you the return address and the return policy,we can give you refund ,but we won't take the return shipping fee.because this is the problem of yourself.



thanks a lot jackass.
I know its my fault for taking forever to deal with this **** but i just found this site and hoping you guys can give me some adivce to deal with this..I kinda knew this tablet was too good to be true just sucks that i had to deal with this...
 

McBub.com

Senior Member
Jan 14, 2012
461
40
hi,dearie
I am Giovanni,from Mcbub, could u tell me ur order number?
and I will help u check all the details, please don;t worry
I will help u solve this issue
this is my gmail,giovanni@mcbub.com
could u contact me ?
sorry for troubled u
Best wishes
Giovanni
 

mejo

Member
Nov 13, 2012
4
0
Sorry but you are not the only unlucky one I received my tablet a week ago Mcpad F1 and I liked it a lot. I left it over night to charge and when I turned it on it was stuck on android boot screen don't know why? So I plugged in the supplied usb in to my computer still nothing I then try to plug it with the suppled ac adapter(there is no light on the adapter to indicated if it was working on not) and now says my battery is completely dead so I try another ac adapter and it now starts charging once it was fully charged I tryed starting it up and it was stuck once again on the android logo so now I had to re flash it because it would not start so I used the supplied usb and the computer would not detect it I try another use cable from my cell phone and it worked so all this trouble because I have a faulty ac and usb adapter thanks McBud now with the new supplied firmware I lost my g-sensor auto rotate and the supplied ac adapter and usb cable.
 

mejo

Member
Nov 13, 2012
4
0
I have contacted cs it took them three days to respond with little help so am am now dealing with pay pal to get a partial refund I dont want to ship it back I shouldn't have to pay for shipping on a defected purchase and I really dont trust you guys anymore
 
Top