Archos 101 short first day review


Jun 23, 2010
Got two of them last night. One for me and one for my wife.

I followed the instructions on the archosfans forum about getting 2.2 installed right away and adding the Android Market. I also did the temporary root thing to speed up the CPU.

It upgraded quite easily. No problems. Just connected to my home wifi and followed the directions. Only problem I had was when I went to get the root .apk file. It failed the first time and after that it refused to download it right ever again. I went to another site, and got it on the first try there.

So far, I like it. I am not unhappy with what I got. Most things are exactly what I was expecting. I won't go over all of that stuff. It has all the features it says it does.

So ... let me start with the things that bug me! :-( Don't take this as a negative review. It's not meant to be. These are the picky things that are important to me, but might not be to you!

There doesn't seem to be any keyboard buffer. It only puts a character on the screen every second or so, and I type faster than that! So, it drops a lot of them. I need to learn to wait between keystrokes. This could end up being a deal breaker. I plan to do a lot of typing. That's why I got the 10" and not a smaller one.

Second, it resets lot. Since the "resets" didn't require restarting the temp root feature, I am pretty sure they are just resets of some kind and not reboots. It displays the boot splash screen for about 10-30 seconds. This may be related to me turning on the security login prompt. I am using the "connect the dots" lock screen. It looks like the same as the keyboard issue where it forgets what dot I started with, and then misses some. Have to do it really slow, to get it to accept the code. And even then, sometimes it still selects the dot, then at the next dot acts like I am starting there instead forgetting about the first one it highlighted. It resets during this also. Seems like the CPU is very busy or something. Need to try without the screen lock and see if it still resets. Once I got in, it did not reset. That only happened about 4 times last night in the first hour, and then once again this morning about the 5th time that I logged into it. It seems better after I manually rebooted it. Had to re-temp-root and apply the CPU speed increase again. That is as that feature was advertised. (That is a hack, not included software.)

Speedwise, it's OK. Not a speed demon, but very usable. My HTC Desire is more responsive. It seems to hang from time to time. After the 2.2 upgrade, I would say you gotta do the CPU speed hack! Without it, the speed is almost unusable. Even sliding from screen to screen has hangs on them without it.

After adding the Android Market, 2 of the 3 apps I paid for on my Desire were there for me to install. I assume the 3rd is not available in that market or something. I downloaded a few others. So far it's good. Shazam has some problem about not connecting, and won't do the setup. I had that on my Desire for after a recent upgrade to it. So maybe I need to wait for another upgrade on this one too.

Web browsing and video playing are as expected. No problems. I added a 4 gig sd card. It spent a while doing some multimedia things with an icon in the upper left screen. Then all of the stuff on the card was available. I have a lot of videos, pictures and songs on that card.

I like the size. It is very wide, but as I said, I want to do a lot of typing. I will look for a better keyboard app for it. I will be getting a screen protector yet. It gets messy with greasy finger prints fast. I have one on my phone, and it does not look as bad, so I think it will help me feel like it's cleaner. :-O

Have not tried to tether it to my Desire yet. I'd like to find time today to try, but unlikely if I keep wasting time writing stuff like this up. ;-)

Not sure how to move applications to the SD card yet. Mabye this is not the version that does that, or maybe it is already doing it and I just don't know it! Have not run out of memory yet, so not a pressing issue.

Otherwise, I'd say it took my about 4 hours to customize it to my liking. Of course, I'll do more of that every day for a long time. But it's a lot like the Android on my Desire, so it was quite easy to set up and configure. There is a LOT more room for icons and widgets on the screens. I am gonna like that part! :-D

More later as I spend more time with it ...


Dec 4, 2010
Hi ya. Sounds like a review i would of written. Exactly the same situation :) if only we could get a 7" desire, I would be very happy.

However give launcher pro ago....feels more responsive then the stock launcher on the A70

Sent from my HTC Desire using Android Tablet Forum App because this app crashes my A70 :(


Oct 15, 2010
Thank you very much jkane for your review and I would like to share mine too. :)

I have bought ARCHOS 101 IT (16 GB) - Android Froyo 2.2.1 form ARCHOS's Distributor in Thailand and have received on December 8, 2010

Default Launcher app very sensitive if i need to move or delete icon, i must softly touch to drag icon. So i have used "LauncherPro Plus" instead of default Launcher.

CPU Speed only 800Mhz by default, if i need 1Ghz, i must root (with 4zroot) and then install setCPU

4zroot just tempolary root only, i can not permanent root. every time i have reboot device i must re root again.

4zroot work fine with setCPU/RootExplorer/Hot Reboot/Titanium Backup but not work for change permission of system files so i can not change fonts or any files in the system. (ARCHOS used squashed file systems not standard Android file system)

Very nice multimedia system (Cinema / Music / Vedio) but at this time SMB (Shared folders) and UPnP (Media servers) not work for me but no problem because i can streaming medias from PC/Notebook to ARCHOS 101 by use "AudioGalaxy" Audiogalaxy - Your Music. Your Playlists. Hit Play from Anywhere. (Free App/Online Web Service just sign up for your account)

I can share files on PC/Notebook (Windows 7) by use this app "ES File Explorer" but still problem when open media files (.mp3/.mp4)

Google Web Browser and Flash 10.1 work fine I can watch Online TV, Youtube and other Flash web site.

Work poor with USB Mouse or Wireless Mouse, i can not use one click on icon or menu i must use dobult click instead.
I can not use Mouse to scroll page anymore.

Problem with link location in Thai Web site, I know how to fix this problem by edit file but i can not push/replace this file in /system/lib

Although it have alot of problem but I would like to say I love my ARCHOS 101 so much.

ARCHOS user in Thailand.

My Tablets:
MID EX900 SERIES Android 1.9.88 V.3 Tablet 7"
ARCHOS 101 Internet Tablet 16 GB Android 2.2.1

My Phones:
iPhone 3GS 32 GB FW 4.0.1
Asus P535 Windows Phone 6.5
Last edited:


Senior Member
Aug 4, 2010
Don't for asleep with it in your hands, if you drop it face front you'll be unhappy..


Jun 23, 2010
Hooked up a usb keyboard. It worked perfectly! Not a good solution, but the keyboard buffer must exist since I was able to type as fast as I wanted with it. Also have had less problems with speed typing since yesterday. Maybe it was somethign happening in the background. Have to test it more.

Could not tether it to my HTC Desire. :-( No settings that make both of them talk. They can see each other with blue tooth, but neither seems to want the other to be anything except a head set, which they are not. Connecting it USB, it ignores it.

Connecting my HTC as a disk drive, makes it say checking drive, and it never finishes. :-( My wife said she got it to work with hers by rebooting while it was attached. I have not tried that yet. Could be a bug if you have to reboot to make it work. I need to get a normal thumb drive and try it also. I get the same symptom with an encrypted thumb drive. I don't trust that it isn't the encryption causing it on that one.

I have not had any resets in over 24 hours! I disabled the password lock screen. I'll give it a couple more days and then turn it back on. It might just be that function that was causing it.

Wish I had wifi at work! It sits next to me, but I can't do much with it. I guess that's on purpose to keep me from playing instead of working. ;-)


Aug 10, 2010
Will just any old usb keyboard work with archos 101? does it buff chars faster than onscreen touchtyping?

What other customizations did you do in your *4 hours*?


Sep 2, 2011
Hi there!
I noticed your reviews and thought I'd share mine... Just what I think, probably not what's true...or correct...
So, my Archos 101 was bought in Slovenia under the name of Prestigio PMP7100c. I paid 289€ for it and I think it's the best you can get for that price.
My 10" tablet becae an Archos when I brought it home. I realized there was something wrong with the hard drive and the notification said 'you may need to reformat your device'
I did it and after a whole night of not sleeping, waiting for the glitched-out-archos-formerly-prestigio to eat its battery, it turned off.
I filled the battery and turned it on. Worked normally, but the splash saying ARCHOS now appeared (extending boot time, which is now 30sec).
So, I found a great collection of free apps online and (of course) installed them all. I noticed a 'move to internal storage' button in Settings>Applications>manage applications and i used it because I was running out of space.
Since then, I had to reformat it less than 10 times (just a little less), at least two formats were my fault because of pernament rooting (a great tut on XDA forums).
The root function soon became useless (except Titanium root) and installed the market with gApps4Archos. That turned out to be a bad idea and (after reofrmating the disk AGAIN) I moved onto Arctools.
The multitouch screen bothers me very much. It only reacts with max. 2 fingers and if it's not greasy, my finger won't slide. If it isn't greasy, the picture is much better but my finger starts jumping because of fraction.
Also, I don't know how to clean the screen and what to clean it with.
The 8 gig are enough for me, although I could use a larger system storage for apps...
Mine came along 2.2 out-of-the-box, but I found a newer version available on Archos' site...
The screen sometimes doesn't respond at all, even after callibration and all i can do is hold the pwr button until the darn thing shuts down.
The camera quality isn't something I'd brag about, but it's useful for...uhm......well, nothing, except if you have skype... I don't cause it keeps running in the background.
CPU and GPU aren't a problem. I'll live with it, but if you have the thing stock pernament rooted, the CPU isn't underclocked, but the max is 1GHz.
Personally, I'm happy with my dad's purcashe for my birthday and I'd reccomend it to anyone who wants a low budget tablet with the best performance.

PSP, IN YO FACE! I think this could even beat an iDevice (iPhone 1 or 2, maybe)