Barcode Scanning programs dont work


Jan 20, 2011
I have tried everything, Apad, Haipad, Epad, Gpad, for all i know they are all the same, but any of these tablets which i have bought from China not a single one of them seem to work with any barcode scanner.

Take Zxing for example and take the HaidPad 701, the app installs and opens successfully. In fact i even see the preview window showing the video, however i place any barcode in front of it, 1D, 2D such as QR and nothing. I can definitely tell the picture is quite clear and i have seen resolutions much worse be able to capture, however here the resolution was quite good and the bars and everything are made out clearly.

I know its not working because one thing which happens when the barcode scanners run is these little yellow dots pop up here and there, and on this i dont see that happened.

When i tried another device such as a MID Apad etc, i get a black screen where the video preview is supposed to be.

So just no luck, does anyone have any ideas on what this is? I am working on a barcode scanning app and would like to get something working on one of these inexpensive tablets.

Btw, one theory is that i notice the Kernel version on most of these Chinese tablets are 2.6.29 when i look at any other smartphone such as EVO, EPIC or Droid they are 2.6.3X