Brickety Brick Brick


Junior Member
May 3, 2015

I got a ZTE S8Q which is a mtk 8 inch Alps device sold to a couple european countries. It's running stock 4.2.2
stock recovery (e3) and it's rooted.
Had installed link2sd and pointed it to a ext4 SDcard partition that was working great. Unfortunately the partition on the Samsung card developed cluster errors and the tablet entered a nightmarish bootloop.

The problem is the bootloop has mounted almost the whole filesystem read only and i'm a bit lost here.

1) adb shell is working in factory mode as a user but i cant su (probably because i'm not in android to authorize the request) so no go there
2) i cant remount the system rw because i cant su so no go there
3) i got no partition that permits writing that isnt mounted noexec and is suid so i can adb push an insecure SU so no go there
4) i'm on stock recovery (e3) so can't change permissions/flash so no go there
5) fastboot mode is working but cant flash recovery because i get partition recovery doesn't allow flash (either bootloader locked or the permissions problem)
6) i suspect that recover-from-boot scripts in /etc locked the filesystem down when the SD filesystem error occured but i cant edit /etc because i cant su so no go there.
7) found some posts online of users that got bootloops with link2sd too but managed to recover either by removing the SDcard or by running permission fixing scripts. I removed the SD but that doesnt stop the bootloop, i cant run the scripts because i cant su so no go there either.
8) i fsck the sdcard and repaired the errors, put it back in, bootloop, no go
9) new SAMSUNG sdcard in, recreated the ext4 and the fat partitions empty, bootloop, no go
10) new SAMSUNG sdcard in recreated the ext4 and the fat partitions and copied the data from repaired card 1, bootloop no go
11) Since fastboot is working i tried both installing a recovery (cwm for E8Q - yeah i know i was desperate) but i get partition recovery doesn't allow flashing errors (probably locked bootloader) and tried to fastboot boot to a kernel/ramdisk too to do the dirty deed externally, no go

Any ideas? Seems i'll find Lord Lucan online before i locate a stock rom for the S8Q. And even then I don't know if stock recovery would allow for a stock rom flashing.

Help people, i liked the little thing, was perfect for my use.
Last edited: