Cant get to Google apps market - HELP PLEASE!!


Feb 10, 2012
I am brand new and havent a clue :confused:

I have an Alphecca Android tablet from china vision.
The instruction book is pretty rugged (just what I need) and has V7 on the front page.
Alphecca - Android 2.3 Tablet with 7 Inch Capacitive Screen and WiFi (4GB)
The specs are at the end of this query.
There is a MARKET icon in my apps screen (of course )
the problem begins when I try to access it.
Hit the icon and a message on another screen says "Goggle sign in" which quickly leads to another screen "Add a google account - adding an account. You can use more than one Google account on your phone (er - hello - its a tablet!!!!) such as your home and work accounts. Adding a google account takes just a few steps. Touch NEXT to continue.
Hit next and the screen has two buttons "create" and "sign in" I have tried both.
The screen after 'sign in" asks for user name and password. I have tried both my usual Gmail account and the new one I opened with the same results.
After signing in the screen says: "Your account needs to communicate with Google servers to set up your account, this may take 5 minutes" And a connection worm starts.
In about 2 seconds, the message arrives on a new screen "Cant establish a reliable data connection to the server. This could be a temporary problem or your phone (phone????) may not be provisioned for data services."
This process is repeated when I hot other app icons as simple as the calendar!
I can use the browser to access my gmail account from the tablet.
When I try to access the android market from the tablet browser I have exactly the same process and problems.

Can anyone please give me some advice?

- Operating System: Android 2.3 Gingerbread
- CPU: Vimicro VC0882 ARM Cortex-A8 process (ARMv7)
- CPU Speed: 1 GHz
- RAM: 512 MB
- Screen: 7 Inch TFT Capacitive Multi-Touch Screen
- Screen Resolution: 800 x 480
- Camera: Front-facing camera
- Camera Resolution: 0.3MP
- Built-in Speaker and Mic
- Battery Type: 4500mAh Rechargeable Battery
- Battery / Run Time (up to): Around 4 hours working time
- Power Device Type: AC adapter v- Voltage required: 100V - 240V
- Color: Black face panel with white back cover
- Languages: English, Czech, Danish, German, Spanish, French, Italian, Dutch, Norwegian, Polish, Portuguese, Swedish, Turkish, Greek, Russian, Arabic, Thai, Korean, Chinese (Traditional), Chinese (Simplified), Japanese
- Dimensions / W x D x H: 190 × 120 × 10 (mm)


Senior Member
Jan 14, 2012
Try to check the time and date on your tablet. For some reason Android Market do not allow you to connect with a wrong date or time.


Feb 10, 2012
You might be right about the wrong date and time - but when I set it it always went back to the Chinese version which was wrong.
What I did in frustration was send it back to the factory settings, which was a bit of a shock when it all went back to Chinese!! So it was very hit and miss for a fair while (instructions hopeless, I think they are for another version) until we turned on English - and guess what - Google appts was available easy peasy!! Ifg I rcall corectly, I fixed the time and date before I got to the apps icon.

Problem is, the tablet has developed another serious terminal power problem so am contacting China. My computer techie friend has bought heaps from this company with no probs - I seem to have gotten a Monday one! We'll see. Thanks again everyone Jen


Mar 14, 2012
Hi there,

i have the same problem with you.

I just opened the box from Chinavasion and i run into the same issue.

Have you gotten it to work with Market ?

Thanks for letting me know!!!