CNM Touchpad 7 Not Turning On or Responding


Jan 22, 2014
I'm having an issue with my daughters Cnm 7. She brought it to me this evening and its not responding what so ever, nor is my laptop recognizing it as an external device when plugged in.
Was working fine this morning, barely 2 months old and left on charge while she was at school. It hasn't been dropped or knocked and is well looked after.
I have held the on button for over a minute...both unplugged and on the mains.
I have tried Vol + (and - as a google search yielded various results) in conjunction with the power on (both on the mains and unplugged).
The OH used his multi meter to check the charger...current is running through both charger and tablet whilst plugged in... (this one was a just because we were ruling out EVERYTHING!)

It is for lack of a better word....dead :confused: No vibrate, no flicker, sound or response..

I'm a complete Tablet noob and at a lost....any further advice on attempting to get it too work would be great, was only working just over 10 hours ago :(



Junior Member
Jan 23, 2015
Hi I have the same problem on a CnM 10.1. Tried various suggested methods but the thing is dead.
This is so annoying.
Plus the manufacturers have gone out of business due to cash flow problems caused allegedly by Argos non
Seems like I'm in a sinking boat surrounded by crocs with no paddle, just a dead tablet.!!

Any comments please.