Coby 9042 WiFi Issues

smzamzow

Member
Jan 11, 2013
1
0
We bought this for our son. He says he has no trouble logging on to the internet at school but we have a very hard time at home. We had a new/faster modem just installed this week and bought a new wireless router ( Netgear N600 Dual band).

It will either let him log on and then disconnect, or will say we are "not in range" when we are standing right in front of it! It also seem to not be reading that there is 2 bands (only recognizes the 2.4 not the 5.0)

Does anyone have any ideas?

Please advise as I am at my wits end here!
 

lllbob

Senior Member
Jan 15, 2013
7
4
It will either let him log on and then disconnect, or will say we are "not in range" when we are standing right in front of it! !


Hmmm.. mine is a mid7033. And it does about the same thing as well.

- When I first turn on wifi.. and connect to my home wifi. Everything works fine usually.
- BUT when I turn Off wifi.. and then later Turn the wifi back on. I get Out Of Range or it Won't even try to connect at all.

So then I leave the wifi on, and have to shut down the coby and turn the coby back on in order for it to connect again.

Hold power button down.. click shutdown. Hold power button down again to turn it back on.

Wow, mine actually connected that time without having to reboot it. Sometimes it does. usually it does not. 2 out of 5 times maybe.
But it always connects right away after a reboot. an annoying waiting on reboot. lol! argggggg...

All I know is the wifi is really buggy on my coby too. It's very annoying. My router is an older Netgear. Using WPA2 encryption.
I tried Wifi Overview app. sometimes it gets it going. but sometimes it don't either. and still have to reboot it.

If I ever find a Fix for this problem. I will surely post it back here, there, and everywhere.

EDIT: I just fixed my wifi not connecting problem! yeah!
1: Download and Install keepwifi app. Enable keepwifi app. (Open it. Click the enable button.)
2: Download and Install wifi toggle widget. Now go to your widgets and add the toggle to your home screen. Click it to Connect or to turn Off Wifi.
:: The page also said to enable airplane mode then click the wifi toggle. Airplane mode was not needed for me.
:: Tested.. I connected and reconnected ten times or more. works for me. wonderfull.

Those apps are free. but are Not Available on getjar, slideme, or amazon market.
You can search google for the apk files, and download them with your tablet browser and install.

Or these apps may also work. Wi-Fi Keep Alive and wifi on/off or Generic Toggle Widget.
Those are available free at the Amazon app store: Install Amazon® Appstore
Create a free amazon account on your pc first. not on the tablet.

Hope that helps someone..

Now I must fix my battery percent always Hanging Up and not refreshing the %. 1 down. 1 to go. lol
 
Last edited:

sbphoto

Member
Feb 15, 2014
4
0
Hello. After hours of trying to fix my Coby Kyros 9042 Wi-Fi problem (sees the network with good signal strength and says "connected" but then says network "out of range" when I try to use it) I need help. Does anyone have a reliable fix for this or does anyone know where/to whom I can send this? I am frazzled.
 

Spider

Administrator
Staff member
Mar 24, 2011
15,788
1,813
Try resetting your router, that often fixes connection problems. (Unplug the router, wait a minute, then plug it back in again.) If that doesn't work, have you tried the fix from post #2 of this thread?
 

sbphoto

Member
Feb 15, 2014
4
0
Hello. Thanks for the reply. I did try to re-set the router and also I tried using a different router without resolution of the problem. I will try to use a "keep wi-fi app".
 

sbphoto

Member
Feb 15, 2014
4
0
Hi, again. I tried the "keep wi-fi" app and still no luck with internet linking. Boy! This is not easy to fix.
 

Spider

Administrator
Staff member
Mar 24, 2011
15,788
1,813
If you tried a different WiFi and it doesn't work there either, maybe you should return the tablet. If you still can.
 

tpaine

Senior Member
Aug 18, 2012
525
130
Hi, again. I tried the "keep wi-fi" app and still no luck with internet linking. Boy! This is not easy to fix.

While working on a similar problem with a coby 9740, found the tablet was very sensitive to certain wifi channels. In this case it was wifi channel 4. Changed the channel on the router to wifi channel 10 and connected without problem. I'm not sure if it was the tablet or the router, but it fixed the problem.

This is a common problem particularly with mid9042 tabs. When you get an answer please report it here to help others.

Good luck.
 

Traveller

Administrator
Staff member
Jun 16, 2012
2,786
968
What brand of router?

The 5.0 is Wireless N I believe and these devices only support Wireless B and Wireless G. However, that won't affect the ability to log on. It only affects the speed of data flow, since the router will fall back to the slower speed. What would affect the ability to log on is if the router is configured to broadcast using only the Wireless N frequency.

Regarding the channel, make sure it's set to 11, the most common channel.
 

iCameronRB

Member
Oct 25, 2013
19
0
Actually, it has to be on Channel 1. I don't know why but the other router I had, after I changed it to channel 1 it connected and it never showed the "Not in range" message again.
 
Top