Craig CMP759 not loading up


Junior Member
Jun 5, 2014
Hi, I'm new to the forum, and joined because I have a problem with my tablet. I have not used it in over a month. When I charged it and tried to turn it on to install some apps for my husband, it got stuck on the loading screen. I have tried sticking a paperclip in the reset spot to no avail. I get to the loading screen and it just hangs there. Right now I am at a loss as what to do. I really hope someone can help me figure out how to get this working again.


Junior Member
Jun 22, 2014
I'd recommend a factory reset. Check this thread for instructions on how to proceed: Factory reset:

If there are no instructions for your tablet, try some of the methods for other tablets. One of them will probably work and you won't hurt anything by trying as long as the tablet has a good charge or is plugged in.

I checked your link but I don't have any volume button and I tried a lot of stuff, mine is stuck on the boot screen and it won't come off the boot screen I am going to bring it to any close lace to fix it. Because I am lost :confused: So reply fast


Staff member
Mar 24, 2011
Hi AndroidUser, Nice to have you as a member of Android Tablets. I'm moving your thread to the Craig Tablets forum for you, where more people familiar with that tablet are likely to join the discussion and try to help you. Good luck!