Cruz Reader: Many issues. want to hack to speed up and add/remove apps


Dec 23, 2011
I have a cruz reader. I think it is R101 but the "about" screen does not say much. Does not even display what Anroid version it is using.

I want to get rid of some default apps. The program offered on the Velocity site does not work. Also despite their claims, when plugged in to USB it never shows up as a device. I was able to flash their upgrade to switch from Borders to Kobo but beyond that any other such attempt at installing a new upgrade only results in the "!" Icon error when booting to flash mode. ( I have Z4Root and have tried this both rooted and not rooted )

I also wanted to install the Dolphin browser but the links all go to the Android Market place which is not available on the cruz. I have it on my phone and like it. I tried directly from the web but it just says it is already installed after I have logged in?? Then it says it will be downloaded to my device shortly ( but instead it is sent to my cell phone )

Have other had similar troubles trying to hack this reader? I have found and tried a number of threads with instructions but they all fail on one level or another with my tablet.

I cannot find how to move apps to external SD card to fee space?

In short, though this is cheap and my first attempt at hacking Android, I have found this device very frustration in that despite all the apparently good instructions to do so, none seem to work.

Any help most appreciated.



Dec 25, 2011
For the love of God. Stay away from this piece o' crap. The T103 is slow, unstable and their customer service (term used jokingly) is horrendous. IF you can get someone on the phone (another joke), they come with a sh_tload of "it must be YOUR fault" attitude.

What's wrong? Everything!

1) It won't update. I followed the instructions for updating the OS and...nothing.
2) I tried to download Kobo and got a blank screen at sign-in. Contacted Velocity who told me to update the OS. Do we see an endless loop here?
3) The last "Customer Service" (Joke #3) rep told me to reset it. Followed the instructions. (See above)
4) After foolishly suggesting that there might be something wrong with it, they wanted proof that I was the owner. Why would I humiliate myself by pretending to own one? I explained that it was a prize (another joke...I got a million of 'em). They wanted proof. Yeah. I'll call Ellen and ask for a letter. Eventually I submitted something that conformed to their high standards, but it was the last time I was able to contact anyone either directly or indirectly.

Their website appears to be "down" which probably translates to "adios suckers".