Curtis Touchscreen Internet Tablet won't turn on!


Sep 23, 2012
I just bought this today, completely brand new. I hooked it to my Windows 7 laptop, the light turns blue. I let it charge for two hours, (almost three now) and then I tried to turn it on. Nothing happens! The pathway doesn't open on my computer either, I checked the "Computer" section and it says no device is found. The light is still lit, I tried three different usb cords that are working yet it still won't connect. It's still charging, I held the button down for twenty seconds and no go. I pressed the reset button on the back, nothing happened. My model is LT4399, Android 2.2. Is something wrong with it or is it just me doing something wrong? :mad: Please help, thanks in advance, Inu.



Welcome to the forum

The main problem is Not to charge the tablet with a usb (PC/laptop) Only use the AC adapter to charge your tablet.

If you want to use the Tablet- USB to the PC/Laptop turn off your tablet first.then connect the usb cable to the tablet then to the pc/laptop usb after turn on the tablet power button and wait for windows 7 to find the device driver, then you will see a USB icon on your tablet screen click it to turn it on Done.

IF not try this

Press the power and vol + buttons on the tablet together when you here a !!Beep!! on windows 7 release both the buttons on the tablet also on your tablet screen you will see a USB icon click it to turn it on

Hope that helps
Last edited by a moderator: