Did I brick my 7 inch UPAD? what to do next?


Sep 18, 2011
Hello, I bought a Upad last june, updated one time the firmware via TFcard flash method. Nothing went wrong. Worked on it for a while, but wanted to loose the Google account because somebody else is going to use it for some time. So tried a reset to factory defaults. It started to reboot, but it was not set to factory defaults. I could not set it to factory defaults anymore.

So I tried to update via TFcard method, but that didn't work and killed my Upad, so it seems.
Have tried so many different firmware versions, but none could flash. With every update attempt, I keep receiving the message:
"Found ZT_E3.spl"
"Press Enter to continue"
I press: the squircle (is that the correct name?)
I see:
"failed burning SPL" that message disappears quickly and then I see: "Update spl failed, press any key to cancel burning SPL"
Nothing is reacting anymore. Rebooting the device, without hitting any buttons gives my a black screen.

When I try burntool it is not recognized by burntool. I hear some beeps of my PC Which indicate a USB device being attached, but burntool does not recognize my Upad. I tried burntool 7.2 and 7.41

Please advice my what to do. I'm pulling my hair out.