Dysfunctional 7" Tablet. Non-Android. Needs to be Wiped


Aug 29, 2012
Hi there Forum.
Admins, I apologize if this thread is in the wrong section. Honestly, I wasnt sure where to place it. Its a mix of issues.
Anyway - I recently acquired this 7" Tablet that runs Windows CE 5.0. It is in perfect condition physically, no scratches, dents or anything.
Still has the stylus and I was able to charge it using a micro-USB cable from my camera.

7 0 Touchscreen Portable GPS WIFI Tablet PC

Upon booting up the system, it functions normally at first. However, then I run into problems.
Anything I do whilst the system is active, is reset once I turn the device on and off again.

For example, whilst on, if I change the date, time, background, user settings or delete folders or uninstall programs – the next time I turn it back on, it is as if I did nothing at all.
Uninstalled programs are back again, deleted folders are back, added folders are gone, and anything I place onto the device via USB, is not there when I reboot. Absolutely bizzare.
If I reformat the 3.85GB hard drive or tiny flash drive it appears to have, even though there is no SD card or USB attached - it does not wipe the system or erase anything.
If I dismount these same drives, reformat and / or delete them, it does no good.

If I make a new folder, then move some pictures to it via USB stick – set one as my background, then turn the device off and on again, then as stated, it is if I never did that.
The folder is not there at all and the background reset.

It reverts to how I found it, with several empty folders, programs like MSN and Skype which do not work. It seems to be locked at 11am 1st April 2009. Some folders,
for example one named 'Nandflash' suggesting an exterior connecting folder, such as a USB, cannot be deleted or opened.

Wireless does not seem to function either. It varies between 'Excellent' signal strength and 'None', when I know there are wireless networks active here.
Whether I can connect or not is irrelevant, it cannot even find them. I have also taken this device to Uni, a restaurant and other public places to verify this.

I have tried the hard reset of supposedly holding down the power button and reset button for 15 seconds, but evidently this does nothing. It just boots up again as usual.

I am wondering if the way to fix this would be a complete reinstall of an OS, such as Windows 7 or Android. However, being a small touch screen tablet, I do not know if that software would be suitable.
I am completely unfamiliar with these sorts of devices and this software. Despite running Windows CE, it appears I cannot use standard installer .exe files and the like downloaded from my usual Windows 7 PC.
Seems Windows CE has to use specific programs designed purely for Windows CE. However this is fruitless, considering I cannot find any on the net, let alone browse in the first place.

Another point to make is that when connected to my fast internet via LAN cable, the pages load ~extremely~ slowly or sometimes not at all. It runs Internet Explorer, and when I tried to install Chrome
or Firefox, it claimed these were not valid CE programs. (Internet works perfectly fine on my PC from which I am posting this, connected to the same Router).

Something else worth noting is how it handles micro-USB devices. It can read SD cards and USB sticks just fine. But if I attach my External 500GB hard-drive via micro-USB cable, it does not read the device.
It does not show up on My Computer and I cannot access it. Instead, the light comes on the Hard-Drive as if it is functioning, but then the power charger icon also appears. It seems to think it is connected
to an AC outlet (Like how I charge the device using a Micro-USB cable, to a USB / AC adapter). Like it is trying to drain power from the External Hard Drive.

On the side is a sticker with a barcode and the Product ID. It is

- Known Specs -
Runs Windows CE 5.0 (Build 0 on Dec 26 2008)
Processor Type (ARM926EJ-S)
87832 KB Ram
DMX9000X Ethernet Driver
Marvell 802.11 GSPI Adapter

I just wish to erase everything on the device and start anew. Preferably with Windows 7, but if that cannot be done, Windows Vista or XP. If that cannot be done, then anything other than what it is running now.
I cannot do anything with the device and I do not know how to fix it. I have tried everything I can think of. I just wish for it to be a device on which I can write wordpad / notepad files, maybe run Steam to chat
with folks, MSN or Skype, and some light net browsing. That is all. I believe this is what it was intended to be used for anyway.

Any and all advice is very much appreciated. I am completely stumped.

- I have posted this same issue on other tech-forums. No one seems to have any idea. Google has shown little information to help. I have no idea.
Last edited: