eGlide XL Pro Screen stuck on ANDROID(text)


May 3, 2013
eGlide XL Pro
10" 4GB memory

Just got this tablet used from a family member we went to turn it on and it is just a black screen with the word ANDROID in white and a blinking dash after it. I tried this reset from another member posting but the screen remains the same: HOLD DOWN the right VOL button (up?) and then press the PWR button for a few seconds, but no more than 4-5...
Release the PWR but KEEP THE VOL+ button down until you see 'something'. It should be a menu with little more than FACTORY RESET.

Any help would be greatly appreciated ;) Thanks!

****Ok I finally got to the reset screen from another combination, reboot the device same issue as above.


Last edited:


May 17, 2013
hey i hope you havent gotten rid of your tab yet but what you have to do is go into recovery mode and wipe your data then go here and download the firmware then extract it on a microSD card then power off your device insert the microSD card and i think you have to hold the menu button while powering it on and let it install. once done if you want i can help you get it rooted and playstore installed and working


Dec 13, 2013
Morning gents, please help. Im awfully stuck here. I have the exact same tablet and im unable to find the recovery menu. The only thing it does do is if I hold menu on boot there is a long delay so im guessing its checking for an SD card update. Im guessing if I use the update in the link above the update will work but ill still be locked out :(

I have need searching the internet for days looking for a solution. I'm trying to wipe my Dads tablet as he is quite old and has forgot his unlock combination. I have tried every button combination under the sun can you explain how you managed to get into the recovery menu please.

Would be most great full.


Junior Member
Oct 27, 2014
Just got this ematic eglide xl pro andriod 3e tablet used from a family member.I went to turn it on and it is just a black screen with the word ANDROID in white and a blinking dash after it.Later on I down loaded and used it with a SD. I got a message that unable to mount from internal SD card. Now i am getting a flashing screen ANDROID in big 1 inch letters. nothing more.some one pls help me