Factory reset not working on an 8" freescale a8 imx515 adroid 2.2


Dec 1, 2010
Hi guys,

I just bought an Apad Android OS 2.2 Freescale Cortex-A8 MCIMX515 was happy with it but my problem was whenever I uninstall any app or remove accounts from it and do a reboot, all those uninstalled apps and removed accounts just goes back. I tried doing a factory reset but still no avail. The sad part is all my downloaded apps and docs were removed but not the ones that I uninstalled. I also tried to wipe factory data from recovery menu but still it just goes back to its original state. Btw whenever I do a factory reset, it's not showing me the calibtration screen after reboot, it will just go straight to the main home screen.
any ideas or tips? thanks allot.This was a rooted device via z4root hoping someone can shed a light on my issue since I already posted this to different forums but still got no reply =(


May 20, 2011
I know what you mean. It happened to me too. The Utopia tablet OS are very buggy & sometimes unstable. I had their Rockchip & now Freescale IMX515 tablets all with very buggy OS. I'd flashed other custom ROMS & it worked better. But I suggest you back-up your original OS to an image file just in case.