Filemate Clear T720 Stuck on Boot Loop


Sep 18, 2012
Hi everyone. Currently, I am having a huge issue with my Filemate Clear T720 Tablet from Wintec Industries. I am stuck on a boot loop, and I have tried various methods to fix it. For instance, I tried doing a factory reset in the Android Stock Recovery, but after that it is still in a boot loop state. I also tried doing a hard reset, but still is in a boot loop state. Lastly, I tried to use ADB or fastboot, but the tablet is not being recognized on the computer, though it is recognized as MTP Device only. In fact, usb debugging is disabled. So basically, I don't know what to do now. I looked up several forums that talk about this issue, but some of them would not work on my tablet. So pls help me! Thanks...


Junior Member
Oct 26, 2014
I have the same problem, did you fix it? I downloaded the rom fix wintecind published for the camera fix on a sdcard but it's not showing up on recovery. I wiped everything I can in recovery but all the folders are still there and it doesn't fix it.