Hallo from France. My Apad rockchip tablet don't boot more


Aug 18, 2010
Hi all,

I am from Bordeaux, south of France
I am owner of a small web hosting company (Mon Site Web Pro : Hébergement internet email pro sites nom de domaine)

I own an Apad Rockchip tablet that worked properly since week and this afternoon, I started it... it did not boot (exactely, it stay blocked on the Menu). I shut off and tried to reboot again. But it does not start.

It stay blocked on the (small) android text or even the screen lights white, green, red, blue ...

Any idea to restart it ?

Many thanks in advance


Super Moderator
Staff member
Aug 6, 2010

How long have you owned this tablet? It may be necessary to return for refund. Some of the generics have poor Quality Control. I would like to assist. If you have a true APAD, they do provide support. There are many generics which are very similar look identical to an APad. Does your unit have a Blue LED?

It may be possible there is a reset button. Does your unit have a reset button? The reset button can be used to reset the device.

In some instances, reinstalling the firmware is the solution. You sound technically astute to reinstall firmware. Unless you can trust the source of the firmware is the same as your unit, do not install. It can have uneven results. Xaueious is the expert on APads, you may want to PM him. He may point you to the source of appropriate firmware and action.

Best of luck