Help! can't find original firmware


Jan 14, 2011
I've looked all over for the right firmware for my tablet: Mid Tablet PC 7" Android 1.6
CPU VIA8508 (ARM926EJC+DSP), 533MHz

I found loads of firmwares (mainly around here), but none that are compatible with this model.
I tried to update the firmware and made a stupid mistake by using the wrong version, and now I can't get the tablet back working again. Could anyone help? does anyone have this model?



Oct 26, 2010
Hi klarence, I need a bit more info in order to ID your tablet:

1. What is the WMT version ? (you can see rightunder while booting / settings/about device)
2. What color LED has it ? Blue or Green ?
3. Does it vibrate when turned on ?
4. What did the box label say ? MID / iRobot / ePad / aPad / SmartPad etc.


May 15, 2011
Hello, this will be my first post. I stumbled across this form by google'n the same issue klarence has. All I can list about mine (beside I'll never buy another one) it is my first cheap tablet.
1) WMT was 2.1.? Barley got a glance at it
2) Blue LED when on, Red when off an charging
3) Never vibrated, but does chime when the sound was on
4) MID is on the manual. All I got was Tablet, charger, and Ethernet/USB adapter.
Also the charger port came loose and got pushed in so I tore it down an fixed (cracking the touch screen in the process)
I got it charging and the LED comes on blue & red but the screen stays black.
But the main issue is the wrong software load I tried before the disaster that got hung up on
"loading software " script
You think there's hope for it? Or just toss and start over?

I've always had iPhone's and Have rebuilt, jailbroke & modified and had good luck with them.
Heard alot about the android software and tablets so I wanted to try it out and see I'd could
Build me a CarPC.
Thanks in advance for any help
Last edited: