I cant connect to wifi :(


Dec 3, 2011
Hi there, I googled this subject and it brought me here but i cant see a response :( I have bought 2 Zepads for my children for christmas and they look amazing BUT i cant get them connected to my wifi. Like alot of people who have posted the same problem, it says it is obtaining an IP adress then it just disconnects :( its very frustrating and I dont want to wrap them up for christmas if i cant get them connected..... any suggestions that may help would be greatly appreciated, thanks :)


Dec 2, 2011
Don't know if this applies to you but I wanted to post this here for the many others who are having connection problems also. I had a Craig tablet and Craig Netbook and each were running Android 2.2 I called Craig and was told that they have a conflict with Verizon internet service because it's Mi-fi rather than Wi-Fi. Crazy. I spent days on both these units doing hours of googling the matter trying to troubleshoot it. I also tried all sorts of things to "wake up" my Wi-fi. (shut the wifi down and then turn the unit off and reboot, or I'd "forget" my manually added network and then add it again. I did this over and over again. Oddly, sometimes it worked and I'd get connected. But not always which was frustrating. The Craig rep was surprised that I connected at all using Verison DSL. So why don't they put that important detail like IN ALL CAPS or something to warn Verizon users of this conflict?