I can't get my android to connect

wallab

Junior Member
May 12, 2014
1
0
I am past being frustrated with this. 3 days ago, my tablet started refusing to connect to our home wifi. I have tried pressing the connect to wifi tab that is the usual way that I've been told works, but it keeps asking me to enter the password. After I re - enter the re - entered password, it still does nothing. My husband's tablet works, as do both of our phones. This is the only Internet connection we have. What do I do now? I'm sort of computer ignorant, so be simple with any answer. PLEASE HELP!
 

leeshor

Senior Member
Dec 27, 2011
6,331
1,037
Welcome to the forum

I assume you have restarted the tablet? Does your husband have the same model? Try forgetting the connection and start over, and/or restart the router. I have additional WiFi fix suggestions you'll find by following the link in my signature.
 

pete1969

Junior Member
May 14, 2014
6
0
hi don`t no if this will help but i had that prob i have got 4 of the same tablets and one of them done the same as yours i found that if i went and changed the wifi channel on my rooter then they all worked fine hope this helps
 
Top