Issue: SDCard no longer mounting/working - Any Advice?


Dec 16, 2012

I've got an AMID-971R, and have enjoyed it generally (though I wish I held out for the second one), but at the weekend just after finding this forum and deciding I would update and root it, it started playing up (before I made any changes) on me.

Basically now the SD Card (both internal & external) fail to mount. When I go into Settings ... Storage the SD Card (Internal) says click to Mount SD Card, which when tapping tries to mount but fails after about 10 seconds and shows the Mount SD Card prompt again. When sticking in an external card (which a week ago worked fine), the card attempts to mount but ends up being listed as having Total Space of 0.00B, an Unmount & Erase SD Card options.

When using adb to communicate with the tablet using shell, I did ls -l on / and got this for the sdcard:
lrwxrwxrwx root root 2012-12-17 19:27 sdcard -> /mnt/sdcard
but things go really screwy when I ls -l in /mnt :
d--------- system system 2012-12-17 19:27 sdcard

My mediocre linux skills are telling me that with no User/Group/Other permissions, that the problem appears to be something to do with that. So I assume that the External SD Card probably is working, but as it is mounted on the Internal SD Card mount point and that mount point is broken, I suspect that is why it isn't working.
I tried "chown root sdcard" & "chmod 755 sdcard" commands in /mnt, but "Operation not permitted" was the result for both. Also tried "adb root" and the chown & chmod commands again, but still nothing. I'm guessing that might be due to not having "rooted" the device (getting root privileges, as opposed to the tablet's current state)?

So although I'm pretty sure I'm going to lose what I had saved on the internal SD card, I'm wondering whether anyone might know how to get around this problem to get it working so I can backup the stuff I want to keep?

I thought perhaps I can still apply the "Rooting" procedure "as-is" and try the chown & chmod commands again. Would that work or am I wasting my time?

Another thought was to apply the Update (copy the from other forum post to SD Card and apply it through Recovery), could that fix it?

Finally I was wondering whether the system is Read-Only, and is there an adb command that I can use to "remount" the system in "writable" mode to make the chmod/chown changes?

I appreciate that ultimately I have to pull the trigger on "losing" everything, so just wondering if someone more knowledgeable could direct me as to whether I'm on the right track or barking up the wrong tree(s).

Thanks in Advance